Docker Auto quite after restarting System

Docker Auto quite after system restart.

i have installed fresh Docker Setup, and it was working fine, but when i restarted my system now it auto quite after opening Docker.

i have tried re-installing my OS for that, but after that i am having same issue again, tried many time reinstalling Docker but each time same issue that work fine after docker installation, but auto quite after restarting system…

i am not even able to debug that is it’s not showing proper error

i have deleted ‘C:\Users\Mushtaq\AppData\Roaming\Docker\settings.json’ it worked but it did not fixed permanently, having same issue after Restart.

any one can help Please?

Not sure if it will work for you, but I’ve been able to get out of the auto-quit loop by running Docker Desktop as administrator.

I have tried this many times but did not worked for me, even though i have reinstall my OS but did not worked

Here is my OS details

image

Same problem on fresh Windows 11 Pro 21H2 22000.739.

did you find any solution to fix this ?

Figured out you don’t need to delete a whole settings.json - you have to only set back licenseTermsVersion to 0. In this case your other settings preserve, but “Terms and Conditions” window appears when Docker starts, and then it loads well. For me it’s enough, no time for research.