Docker Community Forums

Share and learn in the Docker community.

Docker Desktop always starts although disabled


(Straurob) #1
Version: 2.0.0.0-win78 (28905)
Channel: stable
OS: Windows 10 Pro
Edition: Professional
Id: 1803
Build: 17134
BuildLabName: 17134.1.amd64fre.rs4_release.180410-1804

I’ve successfully installed Docker Desktop on Windows 10 Pro. However Docker Desktop always starts when booting the computer.

"Start Docker Desktop when you log in" is disabled

It seems as if this setting is ignored completely. Whether I enable or disable it, Docker Desktop always starts automatically.


Disable docker auto start on windows startup
(Tim L) #2

I have the same problem. It ignores the setting. I even have the Docker windows service set to Manual but yet it still starts upon booting up. Annoying!


(Xgorex) #3

I would confirm the same problem on Windows10 1709. Standard Windows autorun registry does not contain any docker entry.
My Docker for Windows version:
docker_version


(Seppo007) #4

I’m facing the same problem since i switched to Docker Desktop 2.0.0.0-win78 (28905) for Windows.

Docker Desktop Info:
Community version
Version: 2.0.0.0-win78 (28905)
Channel: stable
Build: c404a62

Docker Engine:
Version: 18.09.0

Windows:
Microsoft Windows 10 Education x64
10.0.17134 Build 17134

Hopefully this problem will be fixed in the near future. For now I have to quit Docker each time Windows is booting as far as i don’t need containers in the corresponding session.


(Drigaudiere) #5

Same issue on Windows 10 Pro 1809


(Cranphin) #6

Yup, same here:
Version 2.0.0.0-win78 (28905)
Channel: stable
Build: c404a62


(Benarroyo) #7

This is still happening with version 2.0.0.0-win81 (29211), channel: stable, build: 4271b9e.


#8

Came here to share this sentiment :\


#9

Same problem here on Windows 10 Pro.

Version 2.0.0.0-win81 (29211)
Channel: stable
Build: 4271b9e


(James Telfer) #10

Just wanted to add my voice to those having problems with this, again version 2.0.0.0.0-win81 (29211).


#11

Same issue on Win 10 Pro. It wouldn’t be so annoying if startup chimes (“Docker is starting”, “Docker has started”) could be disabled.


#12

Same problem here :frowning:

on Windows 10 Pro 1803:
Version 2.0.0.0-win81 (29211)
Channel: stable
Build: 4271b9e


#13

Same here:

Version 2.0.0.0-win81 (29211)
Channel: stable
Build: 4271b9e

Windows 10 version 1809


#14

I had the same problem. For those wanting a workaround until an update is available, you can remove the Docker entry from the registry:

1 - Open Regedit
2 - Check “HKCU\Software\Microsoft\Windows\CurrentVersion\Run” and “HKLM\Software\Microsoft\Windows\CurrentVersion\Run” (mine was under HKCU).
3 - Remove the entry with “Docker for Windows”.
4 - Restart the computer.

For me this fixed the problem and Docker is no longer starting on Windows startup.


#15

This fixed for me! Thanks for the workaround!


#16

Uninstalling Docker Desktop for winders… not messing with the registry.


(Roberto Lo Giacco) #17

Mine was also under HKCU\Software\Microsoft\Windows\CurrentVersion\Run and removing the Docker for Windows entry did the trick: thank you!


#18

Uninstalled the docker for now.


#19

Same problem on a fresh installation of Win10 1809.

The registry hack suggested by @qmennens solved the issue.


(Cdaf) #20

To remove via (elevated) PowerShell

Remove-ItemProperty 'HKCU:\Software\Microsoft\Windows\CurrentVersion\Run' -Name 'Docker for Windows'