Docker Community Forums

Share and learn in the Docker community.

How to prevent Docker autostart on Windows


(PhoenixHawk) #1

Hello,

Problem:
I cannot prevent Docker for Desktop from automatically starting.
I don’t use docker every day, and I need my systems resources for my day to day work and not for a HyperV VM that sits idle. It is extremely annoying to wait for it to start up, just to manually stop it again.

Environment:
I have Docker for Windows Version 2.0.0.2 (30215), stable, Build: 0b030e1.
However, this problem also was there with several previous version.

I disabled “Settings” -> “General” -> “Start Docker Desktop when you Log in”

What I tried:
I tried first to factory-reset a couple times. Then I tried re-installing Docker at least 3 times.
I always update docker to the latest version and try to set that setting again, but to no avail.

Question:
What can I do, so that Docker does NOT automatically start when I boot up my system?

Thanks,

Sebastian


(Muhammad Haris Shafiq) #2

If you want to prevent docker from auto-start then follow these steps
1.Open “Task Manager”(Press CTRL+SHIFT+Esc)
2.Click on Startup tab(in Task Manager toolbar)
3.You will get the list of apps that will auto-start when the system boots each time
4.Look for the “Docker Desktop” in List and Disable it.
This will solve your Problem.

Please dont forget to like and “mark it as answer” if it solves your problem
Thanks in Advance…

Regards:
Muhammad Haris SHafiq


#3

Windows 10 and 8.x

  1. Press Win-r . In the “Open:” field, type:

%AppData%\Roaming\Microsoft\Windows\Start Menu\Programs\Startup

Press Enter .
2. Right-click the program you don’t want to open at startup and click Delete.