Docker Community Forums

Share and learn in the Docker community.

Docker CE no automatic startup, EE not usable on Hyper-V/Windows 10?


(Joachimli) #1

I experimented with Docker for Windows the last days and actually got a composition of Linux containers running. However it is obviously not supported to have a composition start at system startup - at least not with Docker CE on Windows 10. I read about workarounds, but none of them appears to be reliable - and ignoring that starting docker after login appears to take ages…
As I am also using Hyper-V 2016 I considered switching to Docker EE. However when I tried to install it, I got


From what I believe to understand, the Containers features is only required to run Windows containers, correct? Thus imho it could be optional rather than a must-have…
Retrying results in a kind of success message. Then continuing to install docker-compose, working around the API version issue described in some other questions, and ultimately trying to run my composition now on EE, but with the message “ERROR:image operating system “linux” cannot be used on this platform”.
Why that? I do run Linux images on Hyper-V installations. Docker CE can run Linux containers. Why cannot EE?
Actually I am running Docker also on Linux VMs on Hyper-V. However I wanted to avoid the installation and configuration issues inherent in that approach and adopt Docker because it allows me to better separate configuration aspects from implementations, and I was hoping that it would be easier for users of my software to follow the Docker on Windows approach and edit some configuration files rather than login on to a Linux host and use editors they are unfamiliar with to achieve the same.
However after my experiments, it now looks as if Docker on Windows is a dead-end. The CE edition because it cannot start containers automatically, the EE version because it does not run on Windows 10 or Hyper-V (and I don´t want to require a more expensive server version).
Any other thoughts?
Thanks, Joachim


(Archimedes Trajano) #2

Once I figured out what Docker for Windows generally does I did away with it except for the client programs and used VirtualBox VMs to run Docker installations (since I am running a 1+2 node swarm) that were generated by a Vagrant script.


(Joachimli) #3

Tested most recent EE on Hyper-V 2019 insider build - still not working.