Docker Community Forums

Share and learn in the Docker community.

Docker Cloud Bitbucket Autobuild creation failing - no error messages


(Winnowservices) #1

Having previously created Automated builds from some of our bitbucket repositories, it seems docker cloud is now failing to create new automatic builds.

On the builds page ( in docker cloud https://cloud.docker.com/_/repository/docker/{organisation}/{repository}/builds I am presented with options for “Github” and “Bitbucket (connected)”.

Clicking bitbucket allows me to configure a build ( select the repo, build settings etc ) but “Save and Build” or just “Save” return me to the “build” page and no build seems to have been saved.

If I instead try to create a build by using the “Configure automated builds” button, I am only presented with the option to configure a build based on github repo (“AUTOMATED BUILD FROM GITHUB”)

I have tried unlinking and reauthorising the bitbucket account ( based on Cannot create Automated build (Bitbucket) ) but to no avail.

Notably, I am now unable to reauthorise the bitbucket account in docker hub. Is this due to consolidation of docker cloud and docker hub bitbucket integrations? Or does anybody have any other suggestions / similar experiences.


(Xwilders) #2

Exact same issue here. No idea how to proceed.


(Jerry Baker) #3

Hi,

Could you try the following steps:

Could you try:

  • Unlinking Bitbucket in your Docker Hub settings: https://hub.docker.com/account/authorized-services
  • Revoke access in Bitbucket - Manage Account > Access Management > OAuth (It will probably still be there even when you unlink in the step above)
  • And then relink on the Docker Hub settings page.

Jerry


(Jerry Baker) #4

If you still have issues after the completing the above steps please open a support ticket with your account details at https://support.docker.com and we’ll take a closer look.

Jerry


(Hgrubst) #5

Same issue here. I’ve tried the steps described but it didn’t help.
I’ve raised a ticket for now.