Docker Community Forums

Share and learn in the Docker community.

Cannot create Automated build (Bitbucket)


(Chukaofili) #1

Hello,

I just tried creating an automated build repo, when i select bitbucket, my repositories are not listed! hence i can’t select one to complete the setup.

Is there something wrong with the bitbucket repositories listing?

Regards,


Docker Cloud Bitbucket Autobuild creation failing - no error messages
(Jerry Baker) #2

Hi chukaofili,

We currently have an open issue with the Bitbucket linking. You can track the status and add comments here: https://github.com/docker/hub-beta-feedback/issues/213

We have ran across some cases where the deploy key wasn’t available on the automated build because it was originally created as public. Users are able to get this resolved by deleting the automated build on Docker Hub and creating a new automated build matching whatever the Bitbucket repo Access level is set to (public/private). Once you’ve deleted/re-created matching the Bitbucket settings a deploy key should be available.

Let me know if you still have issues.

Thanks,

Jerry


(Chukaofili) #3

Hi Jerry,

Thanks for your response. But the issue isn’t with the deploy keys or well i don’t think it is, the problem is I can’t even select a repository to begin with, its just blank!

Regards,


(Jerry Baker) #4

Sorry,

I wonder if your link is corrupted.

Could you try:

  • Unlinking Bitbucket in your Docker Hub settings: https://hub.docker.com/account/authorized-services/
  • Revoke access in Bitbucket - Manage Account > Access Management > OAuth (It will probably still be there even when you unlink in the step above)
  • And then relink on the Docker Hub settings page.

Jerry


(Chukaofili) #5

Hi Jerry,

Thanks, that solved my problem.

Regards,
Chuka


(Magneticone) #6

Hi,

I have the same problem. I can’t list my Bitbucket repositories when I try to configure Automated build.
I tried your recommendations but problem still here.

Can you help me?

Regards


(Ilcheivanovski) #7

Same here, how come you did not solve the issue after 2 years?
Can you provide any help?