Docker Community Forums

Share and learn in the Docker community.

Docker crashing with fatal error

Hello,
First time post on this forum, looking to get some help with my Docker Desktop.

My instance of Docker Desktop keeps crashing, but I do not know what is causing the problem.
The crash seems to happen about 1-2 minutes after Docker Desktop is re-started, the only error shown is “Fatal Error” with the message “Illegal instruction exception”, with an option to reset to factory default or Exit.

After Desktop crashes, Docker itself is still running, and I can launch images from the command line.

How can I find out what is causing Docker Desktop to crash?

Thanks for any help,
Kieran

OS: macOS Big Sur 11.2.3, on MacBook Pro with Intel CPU
Docker Version: 20.10.5
Docker Desktop: 3.2.2 (61853)

A complete uninstall and reinstall of latest version (Engine: 20.10.5, Desktop: 3.3.1) seems to have resolved the problem, but still a mystery what was causing Docker Desktop to crash.

Anyone else experiencing this? I’d like to avoid uninstall/reinstall as I will loose the setup.

Having the same issue. Running brew upgrade --cask docker seems to have fixed it!

I got the same issue. Tried the above ideas, but still not resolved.

Thanks, I don’t have Docker installed via Homebrew.
So, this command above ends with below
brew upgrade --cask docker Error: Cask 'docker' is not installed.

BTW - both Docker and K8s services are working as long as you do not close the ERROR window. that is my workaround for now…

Hello,
this is my solution :wink: It helped me.

killall Docker && open /Applications/Docker.app

5 Likes

Thanks, @rmartis76 this solves my issue.

Thanks a lot @rmartis76, your solution helped me :pray:

Wow… it’s solved my issue… Thank you very much @rmartis76