Docker Desktop 4.30.0 file sharing update doesn't work (possible bug)

Hello,

I have just updated my Docker Desktop to the newest 4.30.0 version and I experienced the following error/bug:
If i modify a shared file on the host, the docker doesn’t update this file in the container. So for example I modify the program code of an app on the host, but I can’t see the changes unless I restart the whole docker desktop.

I experienced the problem on Win10, MacOS is ok.

Tbh this bug makes the whole docker desktop useless. My other problem is, I can’t roll back to the previous version… I downloaded an older installer, but the only text is: “everything is up to date”. Do I really have to uninstall everything just to roll back?

3 Likes

You mean you can’t see the the file inside the container or there is an app that does not restart to use the new code?

If it is really a bug, you can report it on GitHub:

I never downgraded so I don’t know from experience, but if Docker Desktop check whether it is up to date or not, then I understand why you need to reinstall. Older versions could be updated to newer versions as newer versions can understand the old formats and do the necessary conversion but older Docker desktop will not know how to do changes if necessary.

I thought we are alone having this same issue on our project using Docker Desktop on Windows 11. Changes applied to a file on the host on shared directories are not synced up to the container unless Docker Desktop is restarted. So, I advised the team to downgrade to 4.29.0 version where sync up works between the host and container’s shared files and directories.

So just restarting or recreating the container is not enough?

Yes, had tried both and it doesn’t resolve the issue. What restarting only does is sync up the changes one-time and on succeeding changes, it will not sync up – need to restart Docker Desktop again. On local development using Docker, that’s annoying.

Exactly the same experiences what ctberdon said. I tried to recreate the container and the image but nothing has worked. The only solution is to restart the Docker Dekstop every time something changes on the host’s files. That’s not just annoying, but makes local development impossible.

How did you downgrade? Just uninstalled docker and installed a new version? What happened with the configuration and settings?

I’ve just uninstalled the latest Docker Deskop and yeah, the configuration and settings are reset. Then, I rebuilt all my containers. After that, everything worked again!

1 Like

Hello,
I have the same problem; I’m going to uninstall version 4.30.0 and go back to 4.29.0.

1 Like

There is a github ticket for the bug: Files not updating inside container after updating from 4.29.0 to 4.30.0 · Issue #14060 · docker/for-win · GitHub

Instead of uninstalling and installing Docker Desktop, try to run this command in CLI: <installer_file_path>/DockerInstaller.exe install --disable-version-check. This way you will not lose the settings and config. At least for me it worked :slight_smile: (I rolled back to 4.29.0)

1 Like

I have the same problem but on Mac. I’m using Laradock to develop Website.

I’m having the same issue! Will try to rollback a version and see if that fixes it.

Same issue on Windows Host machine. for php:apache image
Restarting the Desktop Docker helps, only for a short while and the issue occurs again. I found a way to do the development by attaching the container to VS Code and working directly on the container but that is not a preferred solution