Docker Community Forums

Share and learn in the Docker community.

Docker Desktop always starts although disabled

Yep same here
Win10 Pro 1809
Version 2.0.0.0-win81 (29211)
Channel: stable
Build: 4271b9e

Why don’t you use the task-manager to disable the autorun?

Right-click on the start-bar > task-manager > click on more details at the bottom > goto to Autostart tab > select Docker for Windows in the list and click on Disable button.

This is not really shorter but less scary in my eyes :wink:

4 Likes

Why don’t you use the task-manager to disable the autorun?

This would work, if docker is started via windows autostart, which it isn’t for me. So that i can’t deselect it in the task-manager.

Btw, even with version 2.0.0.2 deselecting on boot option does not work.

That works fine! Tanks!

For my system (Win 10 Pro 1809, Docker 2.0.0.2), the registry location was at:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\StartupApproved\Run

And two other HKEY_USERS\[xxLONG STRING HERExx]\Software\Microsoft\Windows\CurrentVersion\Run

I had to use the Find menu option to search for Docker for Windows keys by name to get rid of it from startup.

2 Likes

@tony19
Removing the second key worked for me, thank you!

I still wonder why the general behaviour ist not fixed by the docker team.

Ooh, I love messing with the registry!

1 Like

This issue seems to be due to registry entries left over by previous versions.
At one point in time, the auto-start was handled by the following registry value
HKCU:\Software\Microsoft\Windows\CurrentVersion\Run\Docker for Windows

A little later they renamed this value to “Docker Desktop”, but the “Docker for Windows” did not get deleted or taken over when upgrading.

If you toggle the setting “Start Docker Desktop when you log in” on and off, you will see that “Docker Desktop” appears and disappears from HKCU:\Software\Microsoft\Windows\CurrentVersion\Run, which shows that the current implementation works fine.

Conclusion:
After deleting the obsolete “Docker for Windows” value from your registry, the “Start Docker Desktop when you log in” setting shall be honored.

8 Likes

Thanks @reureu, removing the extra entry in my registry helped to beat Docker into submission, now it’s starting only when it’s told to.
Just out of curiosity I uninstalled Docker, and verified that there’s no “Docker for Windows” entry listed under Run. Then I installed Docker, and both Docker Desktop and Docker for Windows showed up. Deleting the extra one fixed the problem again. It looks like Docker installer adds the extra entry every time Docker is installed, but the settings panel changes only one of the two entries.

1 Like

Well spotted @dusandz!
It’s something the team in charge of the installation package for Windows will need to fix.

Thansk @reureu and @dusandz. I can confirm the issue still exists on a clean PC with no previous docker versions installed I am seeing both registry entries.

Kind of disappointing this is still an issue 5 months after this thread was opened…

Is there an ‘official’ bug report?

Windows 10 Enterprise
Version 10.0.17134 Build 17134

Yes, this bug has been reported many times.
I amended this one:

This one says that it shall be fixed in the next release:

Still happening on Window 10 1903…

Worked good for me… at least better than uninstalling.

Still happening :frowning:

I hope they fix it someday…

Aside from the Docker Settings, go to Task Manager and remove it from Startup, it worked for me:

This actually worked for me and I didn’t have to mess around with the registry :slight_smile:

1 Like

Thanks for the full explanation. Toggling the option does indeed do exactly as stated. For quick access to the key, open regedit and paste this into the “Address Bar”:

Computer\HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run

yup, I just installed Docker Desktop on a fresh Windows 10 Pro system and it adds two entries under the “Run” path in the Windows registry, one is named “Docker Desktop” and the other “Docker for Windows”, both pointing to the same “Docker for Windows.exe” executable. And there are somehow actually two “Docker Desktop” entries under the “Startup” tab of the Task Manager. So it’s definitely a bug in the new Docker Desktop installer which somehow still add an old “Docker for Windows” startup entry. And this seemingly trivial (but extremely annoying to the users) bug is still not fixed after nine months?

1 Like