Docker Desktop distro installation failed after upgradation to 4.32.0

My docker desktop was upgraded to 4.32.0. After upgradation, I started receiving the following error when restarting it.

The problem persists even after several restarts.

deploying WSL2 distributions
ensuring main distro is deployed: checking if main distro is up to date: checking main distro bootstrap version: getting main distro bootstrap version: open \wsl$\docker-desktop\etc\wsl_bootstrap_version: The network name cannot be found.
checking if isocache exists: CreateFile \wsl$\docker-desktop-data\isocache: The network name cannot be found

347353003-e5268c6b-d57d-4e38-bddb-8cc0b7769666
*

docker version
Client:
Version: 27.0.3
API version: 1.46
Go version: go1.21.11
Git commit: 7d4bcd8
Built: Sat Jun 29 00:03:32 2024
OS/Arch: windows/amd64
Context: default

docker info
Client:
Version: 27.0.3
Context: default
Debug Mode: false
Plugins:
buildx: Docker Buildx (Docker Inc.)
Version: v0.15.1-desktop.1
Path: C:\Program Files\Docker\cli-plugins\docker-buildx.exe
compose: Docker Compose (Docker Inc.)
Version: v2.28.1-desktop.1
Path: C:\Program Files\Docker\cli-plugins\docker-compose.exe
debug: Get a shell into any image or container (Docker Inc.)
Version: 0.0.32
Path: C:\Program Files\Docker\cli-plugins\docker-debug.exe
desktop: Docker Desktop commands (Alpha) (Docker Inc.)
Version: v0.0.14
Path: C:\Program Files\Docker\cli-plugins\docker-desktop.exe
dev: Docker Dev Environments (Docker Inc.)
Version: v0.1.2
Path: C:\Program Files\Docker\cli-plugins\docker-dev.exe
extension: Manages Docker extensions (Docker Inc.)
Version: v0.2.25
Path: C:\Program Files\Docker\cli-plugins\docker-extension.exe
feedback: Provide feedback, right in your terminal! (Docker Inc.)
Version: v1.0.5
Path: C:\Program Files\Docker\cli-plugins\docker-feedback.exe
init: Creates Docker-related starter files for your project (Docker Inc.)
Version: v1.3.0
Path: C:\Program Files\Docker\cli-plugins\docker-init.exe
sbom: View the packaged-based Software Bill Of Materials (SBOM) for an image (Anchore Inc.)
Version: 0.6.0
Path: C:\Program Files\Docker\cli-plugins\docker-sbom.exe
scout: Docker Scout (Docker Inc.)
Version: v1.10.0
Path: C:\Program Files\Docker\cli-plugins\docker-scout.exe

Additional Info

Windows OS
Edition Windows 11 Pro
Version 23H2
Installed on ‎03/‎06/‎2024
OS build 22631.3737
Experience Windows Feature Experience Pack 1000.22700.1009.0

wsl --status
Default Distribution: Ubuntu
Default Version: 2

wsl -v
WSL version: 2.2.4.0
Kernel version: 5.15.153.1-2
WSLg version: 1.0.61
MSRDC version: 1.2.5326
Direct3D version: 1.611.1-81528511
DXCore version: 10.0.26091.1-240325-1447.ge-release
Windows version: 10.0.22631.3737

I always use admin account to start the docker desktop

Hi there,

I got the exact same issue on the exact same Docker version upgrade as you did. I tried multiple things I’ve found, but the following was successful for me:

Try the following:

  1. Stop Docker Desktop
  2. Run the following command in your terminal wsl --unregister docker-desktop
  3. Run Docker Desktop again (Will recreate the distro)

Note: I also start my Docker Desktop as Administrator each time, so you probably need to run your terminal/Powershell as Administrator like I did.

Hope this helps! It was what worked for me

1 Like

off topic, but this is not the first time I update my docker then failed in various way, can docker team do a proper testing before publicise the update? Something like safe version? Beta version? Alpha version?

It works for me, don’t even require a computer re-open

Unfortunately, it doesn’t work for me after trying what @amg31 mentioned in his post.

It now works in different way now, I have to repeat the three steps everytime I restart my laptop.

One of my colleague found to start docker desktop with normal user (ignore admin user) . It works for me as well in this way. Strange behaviour and unfortunately, I don’t understand this.
@amg31 @imagineuserfordocker

About same here, I restart the computer and I have to type in the command

wsl --unregister docker-desktop

as well each time I restart the computer.

Hi @amg31,

Yes, running the steps with Administrator privileges worked for me.

Thanks!

shall we make a ticket for it,

I already made it

Here you go Docker Desktop distro installation failed after upgradation to docker desktop 4.32.0 · Issue #14183 · docker/for-win · GitHub

Feel free to add any comments to it.

it works. Thanks you so much