Docker Desktop has to be started twice

I am working with Docker Desktop for Windows Version 3.3.3 (64133) and the WDL2 subsystem.

Since recently, when I start Docker Desktop, after a fresh start of my computer. The icon appears in the system tray as usual, but when moving the mouse over it in order to open its context menu, it disappears - a sign that the application stopped again. There is no process any more in the task manager related to Docker.

Only if I start Docker Desktop once more, then it boots up completely.

Is anyone else having this issue?

1 Like

Just to add that when Docker is started for the second time, when it is ready it always again suggests to do the tutorial. No matter whether I follow through all of its steps or skip it, it will re-appear the next time. Also, the weekly tip shows up after that, although I the previous time I chose to not show weekly tips any more. It seems as if the storage of these settings gets lost everytime due to the double restart. And each time Docker Desktop really starts, it behaves as if it was started for the first time after a fresh installation.

It seems to be an Anivirus software issue. With previous versions of Docker Desktop, when launching Docker Desktop for the first time after a fresh boot of Windows, my antivirus alerted that some app wanted to write to the Windows hosts file. Docker Desktop started nevertheless.

With the current version, the same warning from the antivirus software appears, but also it seems to prevent Docker Desktop from starting. So I temporarily deactivated monitoring the hosts file in my antivirus, started Docker Desktop, checked the changes in the hosts file, and then switched the security setting of my antivirus software on again. Since then, Docker Desktops starts just fine.

1 Like

The same problem - persists even after Windows 11 upgrade.

Almost same problem here, before with Windows 10 Pro, now with Windows 11 Pro, different notebooks.
Only, few little differences/notes:

  • I changed also the antivirus
  • It doesn’t suggest me to follow the tutorial and doesn’t behave as after a fresh installation. Simply starts correctly on the second run.

I also have the same problem for months now.

I have to restart it a second time, so that I can work with it.

Also working on Windows and WSL2.

this issue is not appear in Windows Home version, it’s only appear in Windows Pro version, i have tested it.

I’m also facing same issue since windows 11 upgrade

For anyone just reporting seeing the same issue, did you also try the following possible solution?

Yes, thanks, this works. I’m using Windows 10 Pro 21H2.

To permanently deactivate monitoring the hosts file, e.g. with ESET antivirus the procedure is:

Setup → Advanced Setup → Detection Engine (left side) → open ‘Exclusions’ → ‘Edit’ Performance exclusions → Add → open ‘Path’ by clicking on its right side → and navigate to C:\Windows\System32\drivers\etc\hosts → OK → OK (again) → OK (to save the changes) → ‘Yes’ in UAC (User Access Control) → ‘x’ to close ESET → Reboot PC.