Docker Community Forums

Share and learn in the Docker community.

Docker failed to initialize

I have installed docker 3.5.1, used to work fine, then one day it refused to launch and since whenever I launch I get this message:

image

1 Like

Any luck with above error?
For me as well it was working perfect a few days back (maybe 6-7) but now getting this same issue

No luck, I had to install older version (tried 3.3.3).

Having the same issue, how did you install an older version?

Hi,

I raised an issue for this error on GitHub: Issue 11822
In addition, by googling and trying to fix this error, I found there are many people have the same issue.
Please help us fix this problem.

Thanks

2 Likes

Hi all,

According to Docker failed to initialize I resolved this issue by:

C:\Users[USER]\AppData\Local\Docker
C:\Users[USER]\AppData\Roaming\Docker
C:\Users[USER]\AppData\Roaming\Docker Desktop

Once deleted, I didn’t have to do anything else, Docker Desktop started booting up as normal.

88 Likes

it works for me, thanks

1 Like

It`s works for me, Thx!

Thanks for pointing out the directories !

In the log file in C:\Users[USER]\AppData\Local\Docker I found the culprit in my case:

[11:43:09.152][GoBackendProcess ][Error ] msg=“while parsing JSON from C:\Users\[USER]\AppData\Roaming\Docker\settings.json: json: cannot unmarshal bool into Go struct field Content.proxyHttpMode of type string”

I removed all settings lines related to proxy, and the service started fine.
FYI it replaced the “proxyHttpMode” value from false to “system”.

7 Likes

Not works for me.
After deleting these files

C:\Users[USER]\AppData\Local\Docker
C:\Users[USER]\AppData\Roaming\Docker
C:\Users[USER]\AppData\Roaming\Docker Desktop
1 Like

It works for me also, thanks

I found the best solution for myself - I checked AppData\Local\Docker - there is a log.txt, when I opened the file, the error appears "when parsing JSON AppData\Roaming\Docker\settings.json cannot unmarshal bool in Go struct field Content. proxyHttpMode of type string ", I checked this file and removed the proxyHttpMode field. After that, the docker was restored.

13 Likes

It worked for me as well! Thank you so much for posting the solution!

Your solution worked for me as well. Much appreciated! I opened the settings.json file in Wordpad, deleted the line with the text: " proxyHttpMode: “false” " and saved the file. After that Docker started normally again.

3 Likes

I don’t remember when I laughed this hard. Following hint from ccorsano, I, The Smart One, replaced false with “system” in this JSON field.

Guess which error I got next ?

[21:02:51.875][GoBackendProcess ][Info ] msg=“starting backend server”
[21:02:51.876][GoBackendProcess ][Info ] msg=“migrate http proxy mode”
[21:02:51.876][GoBackendProcess ][Fatal ] msg=“error during migrations: proxyHttpMode must be a boolean value”
[21:02:51.881][GoBackendProcess ][Error ] Process died

oh, software is killing me…

I hae a similar problem, frustrated with these errors. One day it works fine and the other day there is some or the other issue. Initially its fun solving these issues but as a beginner its killing the excitement.

I have also tried uninstall and reinstall and the problem persists. Below I have provided the logs I found from the logs document.

[08:30:52.220][GoBackendClient   ][Warning] HttpOS Client: connection timed out.
[08:30:52.527][IPCClient         ][Info   ] (5c1e7562) 8fa11c3c-GoBackendClient-CSharp C->S BackendAPI GET /ping
[08:30:52.527][GoBackendClient   ][Warning] HttpOS Client: connection timed out.
[08:30:52.829][IPCClient         ][Info   ] (ef48f141) 8fa11c3c-GoBackendClient-CSharp C->S BackendAPI GET /ping
[08:30:52.829][GoBackendClient   ][Warning] HttpOS Client: connection timed out.
[08:30:53.134][IPCClient         ][Info   ] (65b865ae) 8fa11c3c-GoBackendClient-CSharp C->S BackendAPI GET /ping
[08:30:53.134][GoBackendClient   ][Warning] HttpOS Client: connection timed out.
[08:30:53.453][IPCClient         ][Info   ] (407e7f0b) 8fa11c3c-GoBackendClient-CSharp C->S BackendAPI GET /ping
[08:30:53.453][GoBackendClient   ][Warning] HttpOS Client: connection timed out.
[08:30:53.765][IPCClient         ][Info   ] (5eb08221) 8fa11c3c-GoBackendClient-CSharp C->S BackendAPI GET /ping
[08:30:53.765][GoBackendClient   ][Warning] HttpOS Client: connection timed out.
[08:30:54.067][IPCClient         ][Info   ] (aa9cb83b) 8fa11c3c-GoBackendClient-CSharp C->S BackendAPI GET /ping
[08:30:54.067][GoBackendClient   ][Warning] HttpOS Client: connection timed out.
[08:30:54.380][IPCClient         ][Info   ] (eaec7f63) 8fa11c3c-GoBackendClient-CSharp C->S BackendAPI GET /ping
[08:30:54.380][GoBackendClient   ][Warning] HttpOS Client: connection timed out.
[08:30:54.693][IPCClient         ][Info   ] (8f125368) 8fa11c3c-GoBackendClient-CSharp C->S BackendAPI GET /ping
[08:30:54.693][GoBackendClient   ][Warning] HttpOS Client: connection timed out.
[08:30:55.008][IPCClient         ][Info   ] (b2e7f848) 8fa11c3c-GoBackendClient-CSharp C->S BackendAPI GET /ping
[08:30:55.008][GoBackendClient   ][Warning] HttpOS Client: connection timed out.
[08:30:55.321][IPCClient         ][Info   ] (92c48810) 8fa11c3c-GoBackendClient-CSharp C->S BackendAPI GET /ping
[08:30:55.321][GoBackendClient   ][Warning] HttpOS Client: connection timed out.

Thank you so much. This absolutely solved the problem.
I had uninstalled and reinstalled with the latest version to no avail.
This solution works!

This worked like a charm

Thank you it worked for me.

This worked for me as well. Not sure if it is necessary to uninstall/reinstall Docker for Windows after deleting these three folders, but I did and it worked.