Docker Failed to Initialize & Docker Daemon Failed

Hello everyone,

I have run into an issue with Docker Desktop that I cannot seem to fix. I installed Docker Desktop 4.7.0 (I also tried with 4.6.1 which works for my teammates) onto my windows machine. The Docker UI refuses to start on my machine giving me no graphical diagnostic info and occasionally giving me the “Docker Failed to Initialize” Error. On top of that The Docker Daemon also fails to execute which leaves Docker truly useless. The bullets below are the things I have tried to resolve these issues. Also it is worth noting that I do have WSL2 enabled with a Docker approved Linux Distro. I also have made sure that Windows has virtualization enabled as well as the hypervisor enabled. It is also worth noting that I am installing Docker with admin privileges. Any help is greatly appreciated.

Docker UI:

  • Running as admin
  • Uninstall then re-install many times

Docker Daemon:

  • Manually stop the Daemon, and restart with admin privileges
  • Restart all Docker services
  • Switched the Docker Daemon with the following comman: “C:\Program Files\Docker\Docker\DockerCli.exe” -SwitchDaemon and restart the services
  • Uninstall then re-install many times

I have about the same problem the docker window that pops up say’s:

Docker Failed to Initialize
Unable to create an instance of Docker.ApiServices.Analytics.SegmentApi:
Unable to create an instance of Docker.Core.GoBackend.GoBackendClient:
Exception has been thrown by the target of an invocation.

What can I do to fix this? Docker will not let me uninstall or reinstall on top of this.