Docker Community Forums

Share and learn in the Docker community.

Docker failed to initialize

I also upgraded recently to the version 3.4.0 (currently, the latest and greatest and the first one that says that it requires only a log-off, not a full restart after the installation). And I also have the exact behaviour and error message. However, in my case the uninstallation/reinstallation did not fix the problem.
Any suggestions? Or should I revert to the version used before?

Edition	        Windows 10 Enterprise
Version	        21H1
Installed on	‎2021-‎03-‎29
OS build	    19043.1081
Experience	    Windows Feature Experience Pack 120.2212.3530.0

I’m assuming you’ve enabled Hyper-V, you must have if it was working in the past. There was someone else who also had a similar problem. I’ll see if I can find his post and if it has any useful ideas I’ll post a link to it here. I guess rolling back to an older version of Windows may be your only hope, although that isn’t a great option. Sorry.

Yes, I have Hyper-V enabled, although I think it was not used by Docker Desktop, which used the WSL 2 backend.
It worth to mention that I run Docker Desktop as a standard, non administrative user (I am a member of the docker-users group).

Finally, it worked with the previous version, 3.3.3.
What is strange is that both installers reported success, but they both:

  • failed to create a Docker Desktop icon on the desktop (option for this was enabled during the installation) (and they also)
  • did not display the message with the need of a reboot (for version 3.3.3) or log-off (for 3.4.0).

Finally, it worked flawlessly with the latest 3.5.1 version (I was not aware that there were 2 newer releases after 3.4.0). It did not require a log-off after installation in order to be ready to be used.

Glad you got it to work.

Hi, I have exactly same problem with version 3.5.2. I’ve tried reinstaling Docker without any success. Win 10 Pro 21H1 build 19043.1110. It was working some weeks ago, now it does not show anything (no system tray icon) except (when I try to run it second time):
image

I have installed docker 3.5.1, used to work fine, then one day it refused to launch and since whenever I launch I get this message:

image

1 Like

Any luck with above error?
For me as well it was working perfect a few days back (maybe 6-7) but now getting this same issue

No luck, I had to install older version (tried 3.3.3).

Having the same issue, how did you install an older version?

Hi,

I raised an issue for this error on GitHub: Issue 11822
In addition, by googling and trying to fix this error, I found there are many people have the same issue.
Please help us fix this problem.

Thanks

2 Likes

Hi all,

According to Docker failed to initialize I resolved this issue by:

C:\Users[USER]\AppData\Local\Docker
C:\Users[USER]\AppData\Roaming\Docker
C:\Users[USER]\AppData\Roaming\Docker Desktop

Once deleted, I didn’t have to do anything else, Docker Desktop started booting up as normal.

88 Likes

it works for me, thanks

1 Like

It`s works for me, Thx!

Thanks for pointing out the directories !

In the log file in C:\Users[USER]\AppData\Local\Docker I found the culprit in my case:

[11:43:09.152][GoBackendProcess ][Error ] msg=“while parsing JSON from C:\Users\[USER]\AppData\Roaming\Docker\settings.json: json: cannot unmarshal bool into Go struct field Content.proxyHttpMode of type string”

I removed all settings lines related to proxy, and the service started fine.
FYI it replaced the “proxyHttpMode” value from false to “system”.

7 Likes

Not works for me.
After deleting these files

C:\Users[USER]\AppData\Local\Docker
C:\Users[USER]\AppData\Roaming\Docker
C:\Users[USER]\AppData\Roaming\Docker Desktop
1 Like

It works for me also, thanks

I found the best solution for myself - I checked AppData\Local\Docker - there is a log.txt, when I opened the file, the error appears "when parsing JSON AppData\Roaming\Docker\settings.json cannot unmarshal bool in Go struct field Content. proxyHttpMode of type string ", I checked this file and removed the proxyHttpMode field. After that, the docker was restored.

13 Likes

It worked for me as well! Thank you so much for posting the solution!

Your solution worked for me as well. Much appreciated! I opened the settings.json file in Wordpad, deleted the line with the text: " proxyHttpMode: “false” " and saved the file. After that Docker started normally again.

3 Likes