Docker Community Forums

Share and learn in the Docker community.

Docker for Mac cannot pull through proxy

Hi,

I spent the whole day trying to pull an image on my MacBook through a corporate HTTP proxy, with no luck.
It is an authenticated proxy, of the form: http://username:password-with-special-characters@proxy.domain:8080
The http_proxy and https_proxy variables are set in my zshrc.
The proxy details are set in the system’s preferences.

When I try to docker pull hello-world without altering proxy settings in the Docker for Mac UI, I got:

Error response from daemon: Get https://registry-1.docker.io/v2/: Service Unavailable

When I also set the proxy through the Docker for Mac UI` I got:

Error response from daemon: Get https://registry-1.docker.io/v2/: Proxy Authentication Required

I can curl https://registry-1.docker.io/v2/ directly.

I tried with and without URI encoding the special characters in my password, doesn’t change a thing.
I used to have some issues with the same proxy on a Linux machine, but got it to work by messing with systemd. On macOs, I don’t know if I can do something similar.

Help would be very much appreciated.

Thanks in advance !

Hi,

I’m having the exact same issue.
Where you able to resolve this?

Thanks

Hi !

No, didn’t manage to solve it. But with the more recent versions (3.3.x), I have a different error.
Now I have ‘Bad gateway’ whenever I try to interact with the docker engine …

Hi!

I was having the same issue, it was related to having a colon ( “:”) in my password. I tried writing the character raw and encoded (“3%A”) but none of those ways worked. Seems like Docker for Desktop is unable to correctly interpret the character.

The way I solved it was setting a new password for my proxy user without colons, and now I’m able to pull and push from the registry without problems.