Docker Community Forums

Share and learn in the Docker community.

Docker for Windows beta - terrible performance [resolved]

docker

(Mattgroves) #1

Expected behavior

Performance on par with Docker for Mac beta when using Couchbase from docker hub

Actual behavior

Terrible performance, making it unusable (on Windows)

Information

I’ve gotten Docker for Windows beta to work; it was slick and easy and I really like the experimental localhost option.

However, I’m trying to set up a couchbase cluster, and that’s when docker execution becomes terribly slow and unreliable. When I do the exact same thing on Docker for Mac beta, it’s super speedy and works great.

Steps to reproduce the behavior

  1. docker run -d --name cb1 -p 8091:8091 couchbase
  2. Login to Couchbase Console (http://localhost:8091)
  3. Follow instructions to setup the Couchbase instance

In step 3, it usually locks up after the first setup step (I just get a spinner graphic in the browser).

Some things to note that might be helpful:

  • I’ve run Couchbase Server outside of Docker on Windows successfully with no performance problems (on the same hardware, in fact, as I’m running boot camp on this mac).
  • I’ve also run in a ‘normal’ non-Mac PC in Windows, so I don’t think it’s a boot camp issue.
  • With Docker for Windows, I experimented with adding more cores, more RAM, to no effect.
  • On Docker for Windows, I ran “docker stats”, and it didn’t seem like the CPU or RAM was being hit very hard.
  • Ultimately, my plan is to have multiple Couchbase servers running in docker (e.g. docker run -d --name cb2 -p 8092:8091 couchbase, docker run -d --name cb3 -p 8093:8091 couchbase), and then joining them into a single cluster. But if I can’t even get one working well, then I doubt adding more will be any better.

Am I doing something wrong? Is there some knob I can tweak to improve performance? Or is this part of the pain of being a “beta” :slight_smile:


(Andymac4182) #2

I just tested this on my machine. It went through as fast as I was expecting it might. I got a spinner but only for 1 second or so. My only change to default is I am using 10GB RAM.


(Mattgroves) #3

I will try that, thanks. Also, it looks like there’s an update (1.12.0-rc2, I was using 1.11.2.x), so I’ll do that as well.


(Mattgroves) #4

Works great now!

I tried it with 10gb like you suggested, and that worked great. But I was curious to see if it was something to do with the upgrade, so I moved it back down to the default 2gb. Still works great. So, must’ve been something in 1.11.2.x that was fixed/changed.

Thanks again for your help @andymac4182


(Andymac4182) #5

The release notes did say something about performance improvements. Glad to hear its working.