Docker get no such image error even I already pull this image on machine

I’m facing some trouble in deploy my service, I’m using Docker Swarm and pushing my image on my machine, but when I deploy the stack Docker keep showing error: no such image nginx:alpine@sha256:5a0df7fb7c8c03e4158ae9974bfbd6a15da2bdfdeded4fb694367ec812325d31. I have try docker run nginx:alpine and it going right (which mean my machine is already had this image). Anyone have any idea for this ?
OS: “CentOS Linux” -VERSION=“7 (Core)”
Docker version: 20.10.1

If it is Docker Swarm, how many node do you have? The image in the error message exists. I tried with the hash, because I thought nginx:alpine is on your machine but the hash could be wrong. It is not.

IF you have only one node, that should work. An other thing I can imagine is that you have multiple Docker contexts. For example one of them is rootless docker.

Run the following command to see if it is the case

docker context ls

You should have only “default”.