Docker Community Forums

Share and learn in the Docker community.

Docker installation Mac OSX


(Katyaa) #1

Hi, I just installed Docker Toolbox 1.8.2. However, when I run docker version, I get the following error:
Get http:///var/run/docker.sock/v1.20/version: dial unix /var/run/docker.sock: no such file or directory.

  • Are you trying to connect to a TLS-enabled daemon without TLS?
  • Is your docker daemon up and running?

When I start Docker Quick Start Terminal, it spits out: /bin/bash: /bin/bash: cannot execute binary file

Any advice on how to resolve this? Thanks!


(Randy L Rasmussen) #2

I am getting the same thing. Additionally I can’t start docker in daemon mode with “docker daemon” (supposedly new in 1.8) nor with the previous docker -d.


(Ranjandas) #3

Hi,

Would you like to try an alternate approach of using docker-machine directly instead of docker toolbox. http://blog.ranjandas.me/installing-docker-on-osx-docker-machine/

Regards


(Katyaa) #4

@Randy, I got it working by restarting the docker machine (docker-machine restart default) and then running this command: eval $(docker-machine env default). After that everything worked for me as expected. The trick is to run the eval command every time you open a new terminal. Also, I left the machine running and don’t use the Docker Quick Start Terminal.