Docker Community Forums

Share and learn in the Docker community.

Experimental docker in a docker container


(Dominique Luna) #1

I’m trying to play around with experimental docker. OSX isn’t supported yet so thought I’d boot up a docker container in a VM and install experimental docker on there. Hasn’t gone as smooth as I hoped :frowning:

I tried running this on ubuntu:14.04 and debian:jessie.

I ran this to get it in the container.

wget -qO- https://experimental.docker.com/ | sh

When I run docker version (or any command) I get

Post http:///var/run/docker.sock/v1.20/networks: dial unix /var/run/docker.sock: no such file or directory.
* Are you trying to connect to a TLS-enabled daemon without TLS?
* Is your docker daemon up and running?

So how do I properly set up the TLS? I think I’ve been spoiled by docker-machine so I forgot how to do that stuff.

Thanks.


(Sven Dowideit) #2

http://docs.docker.com/articles/https/ might help you set up TLS

Sven

Docker Engineer
Ask me anything …
Brisbane, Australia (UTC+10)


(Dominique Luna) #3

Much appreciated Sven. I’ll check it out.