Docker Community Forums

Share and learn in the Docker community.

Docker is starting... forever (solved by reinstall)


(Dimaqqgmailcom) #1

It was a double problem:

Problem1

Working Mac, with VirtualBox (newest, installed, used since boot, not running now)
Installed Docker for Mac, tray icon showed that it was working, but…
docker info or docker ps would always fail.

log error excerpt: Transfuse.Socket_closed

Rebooted Mac, now a different problem, Docker auto-started, tray icon keep shuffling containers, tray icon status shows “Docker is starting”, and doesn’t change.
kextunload’ed all 4 VBox modules, restarted docker, same problem.

log error excerpt: Couldn't create Tag store repositories: EOF

Stopped docker, ran rm -rf Library/Containers/com.docker.* started docker, it asked for key again, provided, now it’s running.

So, my guess is, when Docker ran first time on install it managed to permanently mess up it’s OSX container data.

air:~ dima$ pinata diagnose -u
OS X: version 10.11.5 (build: 15F34)
Docker.app: version v1.11.1-beta12
Running diagnostic tests:
[OK]      Moby booted
[OK]      driver.amd64-linux
[OK]      vmnetd
[OK]      osxfs
[OK]      db
[OK]      slirp
[OK]      menubar
[OK]      environment
[OK]      Docker
[OK]      VT-x
Docker logs are being collected into /tmp/20160525-085740.tar.gz
Most specific failure is: No error was detected
Your unique id is: DD204C10-036B-4E5F-B57C-988ACAEA3510
Please quote this in all correspondence.

Log dump at https://dima.egnyte.com/dl/ztgawj8p8u/20160525-085740.tar.gz_ (includes older and newer errors)


(Jakub Zalas) #2

Had the same problem after a docker update today.

I first tried re-installing docker with no luck. What solved the issue for me is killing all docker processes and wiping out ~/Library/Containers/com.docker.*.


(Wkoszek) #3

Hi guys. I’ve had exactly the same problem. Similarly: removing ~/Library/Containers/com.docker.* solved it.


(Gerhat) #4

Just a note:
Removing ~/Library/Containers/com.docker.* will delete all your images and containers.