Docker Community Forums

Share and learn in the Docker community.

Docker issues on Windows 10


(Dguisinger) #1

I’m hoping someone can prove to me that Docker is worth it because I’ve just spent two days trying to get it to run and for the life of me can’t even get a single command to do anything useful.

I’m running on Windows 10 inside of a Parallels Desktop (v10) VM on my Mac. My goal is to take ASP.NET 5 projects from within Visual Studio and publish them into AWS ECS docker containers. All I’m looking to really do from this box is build container images. This should be easy… I’ve previously used Docker on my OS X side of things and it just worked unlike this mess…

Things I have tried so far:

  • Installing and uninstalling various times, including right clicking on the MSI and installing as Administrator… Including manually deleting my docker and virtualbox directories and verifying the virtual network adapters are gone.
  • Turning my Windows firewall off
  • Various commands around docker-machine for starting/stopping/removing and trying to manage certificates

So on a fresh install, if I open the Quickstart terminal, it sits for about 5 minutes on:
“Waiting for an IP”

When it finally continues it says its provisioning with boot2docker and immediately says:
“Error creating machine: Error running provisioning: Unable to verify the docker daemon is listening”

If I close the terminal and start the Quickstart terminal a second time, it immediately shows me the picture of the whale and says I am up and running, but if I type:
docker-machine ls

It lists the machine but says it is “Unable to query docker version: Get https://192.168.99.100:2376/v1.15/version: remote error: bad certificate”

I can run “docker-machine regenerate-certs default” but it doesn’t seem to help.

Any ideas?


(Siddharth67) #2

From where did you download Docker?
https://www.docker.com/products/docker-toolbox

Try changing a line in start.sh(find it in docker installed directory)
eval "$($DOCKER_MACHINE env $VM)"
to
eval “$($DOCKER_MACHINE env --shell bash $VM)”

This solved many such issues for me.


(Dguisinger) #3

Yes, I did download it from the docker website.

start.sh already has the line of code you suggested in it, well, slightly different:
eval “$(${DOCKER_MACHINE} env --shell=bash ${VM})”