Docker Community Forums

Share and learn in the Docker community.

Restarting local docker machine causes failure


(Mozillalives) #1

I’m getting a strange issue that whenever I start my default docker machine I run into an error when it gets to the “Detecting the provisioner…” step. The error message I get is “Unable to verify the Docker daemon is listening: Maximum number of retries (10) exceeded”. Here’s my setup.

Docker for Mac
Docker Machine Parallels Driver
Parallels 13
High Sierra

I previously attempted to run the the containers directly in Docker for Mac, but I couldn’t due to issue that I think are related to the filesystem issues documented elsewhere. I’ve been able to run the my containers with the following setup for a while now, without any issue (and this included frequently stopping and starting the default docker machine).

Over the holidays though I upgraded my os to High Sierra and shortly after that ran into the issue above. I’ve tried resolving this a few ways. I tried reinstalling Docker for Mac but that didn’t help. It seems the only way to resolve this is to destroy the machine and recreate it (but that also means reinstalling the app that I’m building and that’s quite time consuming.)

Anyone have any ideas on what’s causing this issue? Any help is appreciated. Thanks.


(Mozillalives) #2

I’ve tried a couple of different things over time but it seems like docker-machine provision is the thing that actually works.