Docker Community Forums

Share and learn in the Docker community.

Docker-machine Windows 7 with MITM corporate proxy


(Pdmahaf) #1

Hello,

I have tried every article I can find on how to get docker to work behind our proxy. The corporate proxy does MITM and uses our internal CA Root -> Intermediate -> MITM certificate, which I think is causing docker to spit out the error “x509: certificate signed by unknown authority” whenever I try to pull/run the hello-world sample container from the docker.io repository. My windows browsers work fine because I have the trust anchors I suppose. I have tried seting the proxy server by creating a new docker-machine with the proxy environment to either the real name of the proxy or by setting it to 10.0.2.2:8888 (assuming I have fiddler running). Which one should I put in since its a VM on Windows with a container within the VM (feels like inception here I guess).

Any help on how to get this first piece working for a docker newcomer would be very welcome. I have searched and tried like 20-30 different articles from google with no luck.

Docker version 1.9.1, build a34a1d5 (Windows 7 Enterprise)
Virtualbox 5.0.12

docker@default-try4:~$ docker info
Containers: 0
Images: 0
Server Version: 1.9.1
Storage Driver: aufs
Root Dir: /mnt/sda1/var/lib/docker/aufs
Backing Filesystem: extfs
Dirs: 0
Dirperm1 Supported: true
Execution Driver: native-0.2
Logging Driver: json-file
Kernel Version: 4.1.13-boot2docker
Operating System: Boot2Docker 1.9.1 (TCL 6.4.1); master : cef800b - Fri Nov 20 1
9:33:59 UTC 2015
CPUs: 1
Total Memory: 996.2 MiB
Name: default-try4
ID: JDVV:GBKB:6DFR:S3GI:ZG35:PQJX:WERU:4U3G:X5IB:WP3Y:WVRF:C6MW
Debug mode (server): true
File Descriptors: 12
Goroutines: 18
System Time: 2016-02-05T13:57:49.888235506Z
EventsListeners: 0
Init SHA1:
Init Path: /usr/local/bin/docker
Docker Root Dir: /mnt/sda1/var/lib/docker
Labels:
provider=virtualbox