Docker Community Forums

Share and learn in the Docker community.

Docker won't respond on OS X 10.11


(Ian Carroll) #1

Expected behavior

Running docker commands returns something.

Actual behavior

Running docker commands hangs.

Information

OS X 10.11; fresh install won’t respond to docker commands. My laptop works fine. Tried reset and uninstalling to no avail.

% pinata diagnose -u
OS X: version 10.11.4 (build: 15E65)
Docker.app: version v1.11.0-beta7
Running diagnostic tests:
Error docker ps: timeout after 10.00s
Thread 6 killed on uncaught exception Misc.Failure
Error docker ps: timeout after 10.00s
[ERROR]   docker-cli       docker ps failed: Misc.Failure
[OK]      docker-cli
[OK]      Moby booted
[OK]      driver.amd64-linux
[OK]      vmnetd
[OK]      osxfs
[OK]      db
[OK]      slirp
[OK]      menubar
[OK]      environment
[OK]      Docker
[OK]      VT-x
Docker logs are being collected into /tmp/20160419-210137.tar.gz
Most specific failure is: docker ps failed: Misc.Failure
Your unique id is: CAD196E6-CB03-4BB3-91DD-1716695849FF
Please quote this in all correspondence.

(Ian Carroll) #2

Perhaps this is related to networking being broken.

After running screen ~/Library/Containers/com.docker.docker/Data/com.docker.driver.amd64-linux/tty:

 * Migrating /var/run to /run ... [ ok ]
 * Creating user login records ... [ ok ]
 * Wiping /tmp directory ... [ ok ]
 * Starting networking ... *   lo ... [ ok ]
 *   eth0 ...udhcpc failed to get a DHCP lease
 [ !! ]
 * Testing DNS resolution ... [ ok ]
[...]
docker:~# ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
ping: sendto: Network unreachable

(Ian Carroll) #3

Enabling VPN compatibility mode fixed it for me. Looks like something is funky with its network.