Docker Community Forums

Share and learn in the Docker community.

Docker pull stuck after ubuntu upgrade

OS: Ubuntu Server 20.04.2 LTS (on a ESXi 6.7)
Docker : Docker version 20.10.5, build 55c4c88

Hello, since I upgraded my ubuntu server from 18.04 lts to 20.04 lts, I’m getting stuck when I want to pull an image :

$ docker pull alpine
Using default tag: latest
latest: Pulling from library/alpine
ca3cd42a7c95: Downloading [===>                                               ]    204kB/2.812MB

It start to download and then get indefinitely stuck, my server has a good internet connection (2.5G) so that’s not the issue. I tested several images and I have the same issue.

I tried to restart the server and also tried to remove docker and reinstall it but still nothing to do. I don’t know what to do next, does any one has any idea ? I already lost 1 day searching different things without any solution…

Thank you

I just needed to restart Docker.

Linux users can use sudo service docker restart.

Docker for Mac has a handy button for this in the Docker widget in the OS X toolbar: Docker for Mac in the OS X toolbar with restart button

If you happen to be using Docker Toolkit try docker-machine restart.

Like I said above, I’ve already tried to restart everything, I even reinstalled docker and I still get the same problem.