Docker Community Forums

Share and learn in the Docker community.

Docker Registry on other host not working on windows but on linux

Hello everyone,

I am trying to get a docker swarm network going and to distribute Images accross the different hosts in my swarm (currently only boot2docker machines) I have setup a secured private registry in a docker container. To make working with the different hosts easier I have also setup a bind9 container as my DNS server.

My registry is hosted on the machine 192.168.178.36 and has the dns entry 001.registry.swarm. I have installed the required certificates for my registry to work on all the hosts and the registry is working fine when I access it from another linux machine. I can login and push and pull images. But when I try to do so from my windows PC i get the following message:
“Error response from daemon: Get https://001.registry.swarm/v2/: dial tcp: lookup 001.registry.swarm on 192.168.65.1:53: no such host”
after 15 minutes or so I get this message:
“Error response from daemon: Get https://001.registry.swarm/v2/: x509: certificate signed by unknown authority”
Reinstalling the certificate on my windows pc brings me back to the first error message.

Do you have any idea on how I can fix this? Docker for windows is driving me crazy.

P.S. Do you have any tips for working with a bind9 container together with windows? My windows PC takes hours to recognize the dns server.

i have exactly the same Problem.

i have not solved this yet, but what i have tried might be useful to you.

to fix the no such host error message i shh’d into the docker host machine using a dubious unsecure privileged image which could mount the host system (depends on your setup, i have Hyper-V with DockerDesktop)

then i changed

image

to “nameserver your.name.server.xyz”

which got me to
“Get http://someNameOnTheNetwork:5000/v2/: dial tcp: lookup someNameOnTheNetworkon your.name.server.xyz:53: server misbehaving”

Thanks for the response. Windows and Docker for Windows are still driving me crazy.
I will try to get this going with the WSL 2 backend. I will report back if I get it working.

No, didn’t work. I think it’s impossible to run Windows as swarm manager

Okay, here is my solution:

  1. You cant’t run Docker Desktop as a swarm manager. You need a Linux OS to be the swarm manager. This can be a VM tho.

  2. The problem with my DNS was that my PC had an IPv6 DNS configured by the Router and it seems like Windows does not like using IPv6 and IPv6 DNS together at all. The easy solution was to grab the IPv6 from the Container and configure this as my DNS. Doing so makes my PC recognize the DNS immediately.