Docker Community Forums

Share and learn in the Docker community.

Docker Set up issue

This forum is not an official product support or issue reporting channel.

Issue Description :
After Installation when try to start Docker Desktop App . getting message as Docker desktop service is starting in the system tray and then immediately its getting disappeared.
when I m giving any docker command from cmd or Powershell interface , getting following error.

docker: error during connect: Post http://%2F%2F.%2Fpipe%2Fdocker_engine/v1.40/containers/create: open //./pipe/docker_engine: The system cannot find the file specified. In the default daemon configuration on Windows, the docker client must be run elevated to connect. This error may also indicate that the docker daemon is not running

Can anyone help me for this issue.

If the icon disappears this means Docker is not starting. Go to the Windows Event Viewer to see if you find more information in the Windows Log.

Hi ,
Thanks for your response. I am getting following error in the windows log.
Faulting application name: Docker Desktop.exe, version: 2.3.0.45519, time stamp: 0xe8002664
Faulting module name: KERNELBASE.dll, version: 10.0.16299.15, time stamp: 0x4736733c
Exception code: 0xe0434352
Fault offset: 0x0000000000013fb8
Faulting process id: 0x4b80
Faulting application start time: 0x01d64ea4ac073b79
Faulting application path: C:\Program Files\Docker\Docker\Docker Desktop.exe
Faulting module path: C:\Windows\System32\KERNELBASE.dll
Report Id: 09ca5c10-354f-4037-a265-88ac3aa63c32
Faulting package full name:
Faulting package-relative application ID:

Request you to guide me for next steps.

I actually don’t know what the reason for this error is. You give no information about your system, so there are a few questions, like: Do you have the required Windows version for this version of Docker Desktop? Is WSL 2 installed? Is the WSL kernel up to date?

I was having the same issue. Turns out somehow my docker config.json file (located in user home/.docker folder) was corrupted with ‘null’ values. I edited that file to contain valid json (just opening and closing braces) and now docker starts up. I then ran ‘docker login’.

1 Like

This solved my issue as well, my file was containing nothing but spaces, replacing these with just an opening and closing bracket helped.

Thanks @sonatyperuss. That’s fixed it for me. Really appreciate it. :grinning: