Docker Community Forums

Share and learn in the Docker community.

Docker setup on Raspberry Pi - Newbie issue?

Hi everyone,
I am new to docker but am trying to learn it. If this is in the wrong area please let me know so I can post in the proper area,
I have set up Docker across 9 Raspberry Pis - 1 Pi 3B v1.2 and 8 Pi 2B v1.1 - all running Raspberry Pi OS - Buster.
I am using Docker version 20.10.1, build 831ebea.

I was able to get docker installed on each of the nodes… the plan was to set up the Pi 3 as the master node and the Pi 2s as worker nodes in a swarm (the Pi 2s won’t support Kubernetes).
On each node I ran the following commands:
sudo sh get-docker.sh
sudo usermod -aG docker pi
sudo systemctl start docker.service
sudo systemctl enable docker.service

I tested each node with
docker info
docker run hello-world

Up to this point, everything seemed to be fine. Things went bad after I ran ‘docker swarm init’ on the manager node. I got the proper response back i.e. “Swarm initialized: current node (bs499uw1hmaw0zomvmlk1fg9e) is now a manager…”
I joined 1 node to the swarm as a test and got an initial time-out, but a bit later, docker info showed that it was part of the swarm.

At this point the Pis that are part of the swarm become very slow - 30 - 40 second delay on keystrokes etc, but CPU usage is almost 0. Running ‘docker node ls’ on the manager took about 2 min to respond.
top shows CPU at 98% idle - memory is about 60% used, swap is 100% free… vmstat shows nothing swapping.

When I run ‘docker swarm leave’ on the worker, its response goes back to normal and when I run ‘docker swarm leave --force’ on the manager it also goes back to normal

Any suggestions or ideas would be appreciated.