Docker Community Forums

Share and learn in the Docker community.

Docker starts, but trying to do anything results in "error during connect"


(Danharner) #1

Running Docker for Windows on Windows 10 Pro.

I’m brand new to docker and trying to learn. Attempting to do anything results in error like this:

docker version
Client:
Version: 18.03.0-ce
API version: 1.37
Go version: go1.9.4
Git commit: 0520e24
Built: Wed Mar 21 23:06:28 2018
OS/Arch: windows/amd64
Experimental: false
Orchestrator: swarm
error during connect: Get https://192.168.99.100:2376/v1.37/version: dial tcp 192.168.99.100:2376: connectex: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.

I presume it’s trying to connect to the daemon but have no idea why or how it is configured to use that particular IP address.


(Sadaf) #2

Did you manage to figure out the issue? I am experiencing the same issue on Windows 10 Home.


(Hrdrck) #3

Same here?
any solutions?


(Bindum) #4

Hi, I am also facing the same issue, error during connection on docker version 18.03.01 on Windows 10 Pro. Any help ?


(Samsonluk) #5

Try right click on docker tray icon then pick “Restart”

this will restore network access, otherwise, cannot access network even within docker container.
I found “Restart” docker need to be done every time machine reboot, is this a bug?


(Mdeering24) #7

So I was having this issue and I was able to get my docker to work properly. Below are the steps I used but i don’t know if they will be for everybody.

I found out the main issues were stemming from me having ‘Docker Toolbox’ installed before changing to ‘Docker for Windows’

  1. Uninstalled ‘Docker for windows’ (make sure Docker Toolbox and VirtualBox are uninstalled as well)
  2. Go to C:\users[USER] directory and remove ‘.docker’ directory if it is there.
  3. Remove Environmental Variables:
    1. go to control panel/all control panel items/ system click on ‘advanced system settings’ in the advanced tab click ‘Environment Variables’
    2. Remove the below variables by highlighting them and clicking delete. CONFIRM deletion by clicking ‘ok’

variable:

  • DOCKER_TLS_VERIFY
  • DOCKER_CERT_PATH
  • DOCKER_HOST
  • DOCKER_TOOLBOX_INSTALL_PATH

You might want to restart you computer just to be safe.