Docker Community Forums

Share and learn in the Docker community.

Docker tags not updating

I’m trying to publish a new version of my image to jamesatjaminit/jam-bot:dev, the docker publish command completes successfully however the new tag is not visible on the docker hub website, nor when I try to pull it. Is there anything which could be causing this? I doubt it’s my command usage since I usually use Github Actions, and that stopped working too.

Docker publish output:

PS C:\***\Jam-Bot> docker push jamesatjaminit/jam-bot:dev
The push refers to repository [docker.io/jamesatjaminit/jam-bot]
24e376afc3d1: Preparing
835371a588ae: Preparing
2eb6765130f0: Preparing
75769ca1847b: Pushed
58b76c61e454: Pushed
c45c6331ec72: Pushed
ba1fba702e90: Pushed
0ddf3378b186: Layer already exists
110d3632d653: Layer already exists
a46c3bae9c2e: Layer already exists
b485db677a87: Layer already exists
6cdb6a376c8b: Layer already exists
a5e5ff41e5d3: Layer already exists
0ac0b7cace95: Layer already exists
ee64586bec22: Layer already exists
040a44cff5e0: Layer already exists
dev: digest: sha256:1f2f82ba21326d0d811f8a167ba3c5447ddb4857141187de2d6d75fea3e2a900 size: 3681

Hello,

I noticed the same thing whilst trying to update my images. Images are being updated actually. (You can try pulling them, it works)
But somehow you cannot see them on Docker Hub

If pulling the image works then don’t worry about it. Just list the supported tags in the description. I almost never go to the tags page except when there is no description. The tag may appear later

1 Like

I wish I had seen this forum thread before. I am just following a beginners’ training and tried my first push… I’ve then spent half of the night trying to figure out what I was doing wrong, before giving up. :frowning:

Seems everything is back to order, though.

I am also facing the same issue but not found any solution.

I tried to upload new test images and the tags appeared immediately. The only thing I have noticed that the order of the images was in reverse. About 2 minutes later when I uploaded more than 10 images (there could be 25 on one page) suddenly the order was right and my last uploaded image went to the top of the page. What happens when you try to change the order using the “Sort by” drop down list?

If it doesn’t help, can you give us an example image which we can see (or try to see) on Docker Hub and try to pull it?

1 Like

Seems to have been what @rimelek had said, the image was actually updating, just the tags page wasn’t. Thanks for help everyone ^^