Docker Community Forums

Share and learn in the Docker community.

Docker toolbox not running on Windows 10 Home (with virtualization)

Hi,
This is my first time running docker on a windows machine (previous experience has been with Mac, where it worked perfectly OOTB). I’m running on Windows 10 Home, which I know doesn’t support Hyper-V. So I downloaded and installed Docker Toolbox, which should run on VirtualBox.
I followed the instructions and checked that virtualization is enabled in BIOS and have confirmed this is visible to Windows (in Task Manager / Performance tab).
When starting the Quickstart Terminal I’m seeing the following:

Running pre-create checks… Error with pre-create check: “This computer doesn’t have VT-X/AMD-v enabled. Enabling it in the BIOS is mandatory” Looks like something went wrong in step ´Checking if machine default exists´… Press any key to continue…

I’ve tried both enabling and disabling virtualization, and disabling and enabling secure boot from BIOS. Neither of these seem to have any impact on this issue.
The only other option I can see will be to boot up an Ubuntu instance, and run Docker from there. Very tempting!

Facing same issue. Were you able to resolve?

Exact same issue here, any resolutions?

Using Windows 10 Home.
Been using docker toolbox for quite a while, never had this exact issue.

I’ve been experimenting something with android emulators (BlueStacks, MEmu) and during this time, my computer completely froze and I had to force shutdown it.
After restarting, my docker broke completely so I figured I’d fresh reinstall everything including VBox and all.

Ever since I’ve done that, I can’t get it to run, I keep getting the same error message.

I was able to create a Vbox machine by doing the following:

  1. Opened Git terminal.
  2. Navigated to docker toolbox folder.
  3. Ran: docker-machine create default --virtualbox-no-vtx-check

Seems like this extra parameter bypasses this check that was returning an error, and it finally allowed me to create a new machine. From there on - I was able to see it in Vbox and modify it there, currently running containers on Kitematic, all seems to work fine!

1 Like

I was getting the same error as others above and this fixed it for me, thanks shivashadowsong!

You can also go into control panel and then into program and features. click on turn windows features on or off. you can check the virtual machine platform and then you can also check windows subsystem for lynux. you can also do a command in powershell to turn on hyper v.