Docker Community Forums

Share and learn in the Docker community.

[docker-toolbox windows v17.10.0-ce] docker-machine scp myfile default:/tmp doesn't work anymore


(Fcourtault) #1

[docker-toolbox windows v17.10.0-ce]

docker-machine scp myfile default:/tmp doesn’t work anymore
This works previously.

The workaround I have found is to use the git command:
“c:\Program Files\Git\usr\bin\scp.exe” myfile docker@192.168.99.100:/tmp
And use the tcuser password.

But it’s less convenient, right ?

Is it a regression ?

Best Regards.


(Fcourtault) #2

Hello,

Any answer or solution to this issue ?

Best Regards.


(Fcourtault) #3

Hello,

No one other than me has met this issue ?
Strange …

Best Regards.


(Bjego) #4

Same issue here.
I fixed it by installing Docker-Toolbox 17.05.

  • Uninstall docker toolbox
  • Uninstall virtualbox
  • Delete folder %UserProfile%.docker
  • Delete folder %UserProfile%\AppData.docker
  • Download and install Docker-Toolbox 17.05 (I got it from a networkshare)

My OS is Windows 7 and I am using an inhouse docker repo (artifactory).
image


(Bjego) #5

I raised an issue in github : https://github.com/docker/toolbox/issues/713


(Fcourtault) #6

Hello,

Still have the issue with v17.12.0-ce. The only steps I haven’t done is to remove %UserProfile%.docker and %UserProfile%\AppData.docker.
But I don’t see the link between these folders and the scp issue, as mainly, those ones contains iso, and certificates/keys.

Best Regards.


(Fcourtault) #7

Hello again,

Still not working using v18.01.0-ce :disappointed:

Best Regards.