Docker Community Forums

Share and learn in the Docker community.

Docker windows installer doesn't let you choose drive


(Nev9n) #1

Expected behavior

Installer should let you choose installation drive. Best practice is to default to C: drive but have option to install to another drive.

Actual behavior

Installer installs to C: drive with no options to change this

Tested on Windows 10

It would also be nice to be able to configure the storage location for images/volumes - if this is possible I haven’t seen the option anywhere.


(J3rd) #2

Absolutely, changing where the app is installed to as well as the location of images. I run a m2 ssd for main and raid-0 ssd’s for my vms. (I’m sure we aren’t the only devs with setups like this).


(Cjmac) #3

Ditto.

I’ve tried installing the MSI and explicitly specifying the target directory (msiexec /i InstallDocker.msi TARGETDIR="D:\Docker" /qb)… I just end up with an empty D:\Docker, and the rest of the files still end up on C:\.

I have Hyper-V configured to put its VM hard drives on a different drive by default, and the VM Docker creates does end up where I wanted it - but Docker’s program files are still on C:. I guess that’s close enough for me, but I’d like some confirmation - is Docker actually storing everything on the MobyLinuxVM VHD?

Edit: For that matter, it’d be nice to be asked about the VM settings before it got created - my naming convention’s been messed with.


(Egor999) #4

I agree,

Having an option to choose an installation location is critical. Please add this! :slight_smile:


(Bernd) #5

Same here. Will I be able to choose the installation directory somewhen soon? Thanks.


#6

Found a work around of sorts.

  1. start an Admin command prompt (cmd.exe) and change directory to wherever you’ve saved the installer.
  2. change the following environment variables to start with the drive letter you want ( e.g: set=ProgramFile=F:\Program Files )
    image
  3. Execute the installer by running from this cmd window.

Haven’t fully tested, but it looks like it installed to the right spot now and not defaulted to C:\ drive.


#7

Thanks giroux7103. One extra step for me was to change the PATH environment variables to ensure that docker binaries were pointing to new drive (D:\ in my case)
image