Empty mounted directory and can't share drive

OS: Windows 10 Home
Docker Toolbox version: 17.04.0-ce, build 4845c56
Virtualization using VirtualBox v5.1.20 (with extension packs installed FWIW).

When trying to mount a host directory from within the Quickstart Terminal I get weird results.
E.g., if I mount /c/parent_dir/child_dir:/opt/somedir, then /opt/somedir will be empty, but if I mount /c:/opt/somedir, then /opt/somedir will contain only parent_dir (but not any other directories i have under /c), inside it I will find child_dir (but not any other dirs under parent_dir) and child_dir will still be empty.

When mounting a directory under /c/Users I am able to see its content.

I see many references regarding the Docker Settings Whale that should be right-clicked, but I don’t have it. There’s nothing Docker-related in my systray and not in the Docker Toolbox installation dir.

So I tried mounting via VirtualBox’s Settings dialog of the “default” machine.

  • When mounting C:\ to the default C_DRIVE I still get no results.
  • Trying to mount ‘\?\c:’ to ‘c’ didn’t work either 'cause VirtualBox disables the OK button.

So I switched off the terminal as well as the “default” machine and tried adding a SharedFolders entry to default.vobx file: <SharedFolder name="c" hostPath="\\?\c:" writable="true" autoMount="true"/>
Although I am able to see the shared folder inside “default”'s settings in VirtualBox, the result remains the same - the mounted folder is empty.

I went over many many posts in the forum, on Google and on github’s issues list and I can’t crack this one.

Any help on the matter of mounting a folder and/or on the matter of the missing settings applet would be appreciated.

To get better volume mounting, you have to use Docker for Windows (which requires Windows 10 Pro because Hyper-V is required). You’re using Docker Toolbox, which only supports mounting folders in C:\Users<your-user>.

1 Like

Sad to hear that it’s only supported in Windows Pro.
I even tried to “fool” the system by creating a junction link from within the C:\Users folder to a folder outside C:\Users, but no luck.

Thank you for the reply.
At least now I know why I got the Docker Toolbox installation instead of the full Docker for Windows installation.

Update to whom it may concern:

Instead of running Docker on Windows and hooking it up to the “default” VirtualBox VM, I switched it around to running a VM with Docker installed in it.
I then mounted my out-of-C:\Users-directory shared-folder on the VM and am able to map Docker directories as I see fit.
This way I don’t need to move any directories on the Windows host (into C:\Users…).

The only diff I see is that the images are now created inside the VM instead of on the host machine, but I can live with that.

This is exactly my problem, and I also was digging the web for no answer!..

In my case however, mounting C:\Users in the shell only makes available a home dir of the user who installed the ToolBox, and still no files in it. Fantastic, just cannot overcome this… And weird that it is not explicitly mentioned in the ToolBox documentation.
Will try to make it from inside the VM. But if someone has comments or other solutions, much welcome.

Thanks @friism spent a couple days going crazy wondering why this was not working on toolbox in C:\blah This should really be included in the official documentation