Docker Community Forums

Share and learn in the Docker community.

Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages

Hi,
I’m trying to install the latest version of Docker CE in Ubuntu 16.04 Xenial. I installed Docker CE CLI and Containerd.io without any problems. But Docker CE gives this error:

The following packages have unmet dependencies:
fontconfig : Depends: fontconfig-config but it is not going to be installed
libfontconfig1 : Depends: fontconfig-config (= 2.11.94-0ubuntu1.1) but it is not going to be installed
libfontconfig1:amd64 : Depends: fontconfig-config:amd64 (= 2.11.94-0ubuntu1.1)
libgnome-desktop-3-12 : Depends: libcairo2 (>= 1.14.0) but it is not going to be installed
Depends: libgtk-3-0 (>= 3.9.10) but it is not going to be installed
libonline-accounts-daemon1 : Depends: libonline-accounts-client1 but it is not going to be installed
liboxideqt-qmlplugin : Depends: liboxideqtcore0 (= 1.21.5-0ubuntu0.16.04.1) but it is not going to be installed
Depends: liboxideqtquick0 (= 1.21.5-0ubuntu0.16.04.1) but it is not going to be installed
libqmenumodel0 : Depends: libqt5gui5 (>= 5.0.2) but it is not going to be installed or
libqt5gui5-gles (>= 5.0.2) but it is not going to be installed
libqt5multimedia5 : Depends: libqt5gui5 (>= 5.2.0) but it is not going to be installed or
libqt5gui5-gles (>= 5.2.0) but it is not going to be installed
libqt5multimediaquick-p5 : Depends: libqt5gui5 (>= 5.0.2) but it is not going to be installed or
libqt5gui5-gles (>= 5.0.2) but it is not going to be installed
libqt5quick5-gles : Depends: libqt5gui5 (>= 5.5.0) but it is not going to be installed or
libqt5gui5-gles (>= 5.5.0) but it is not going to be installed
libqt5quickparticles5 : Depends: libqt5gui5 (>= 5.3.0) but it is not going to be installed or
libqt5gui5-gles (>= 5.3.0) but it is not going to be installed
libqt5x11extras5 : Depends: libqt5gui5 (>= 5.0.2) but it is not going to be installed or
libqt5gui5-gles (>= 5.0.2) but it is not going to be installed
libubuntugestures5 : Depends: libqt5gui5 (>= 5.0.2) but it is not going to be installed or
libqt5gui5-gles (>= 5.0.2) but it is not going to be installed
libubuntutoolkit5 : Depends: libqt5gui5 (>= 5.0.2) but it is not going to be installed or
libqt5gui5-gles (>= 5.0.2) but it is not going to be installed
network-manager-pptp : Depends: ppp (< 2.4.7-2~) but it is not going to be installed
Depends: ppp (>= 2.4.7-1+~) but it is not going to be installed
Depends: pptp-linux but it is not going to be installed
python-pyside2.qtgui : Depends: libqt5gui5 (>= 5.5.0) but it is not going to be installed or
libqt5gui5-gles (>= 5.5.0) but it is not going to be installed
python-pyside2.qtquick : Depends: libqt5gui5 (>= 5.0.2) but it is not going to be installed or
libqt5gui5-gles (>= 5.0.2) but it is not going to be installed
qml-module-io-thp-pyotherside : Depends: libqt5gui5 (>= 5.0.2) but it is not going to be installed or
libqt5gui5-gles (>= 5.0.2) but it is not going to be installed
qml-module-qtquick-layouts : Depends: libqt5gui5 (>= 5.5.0) but it is not going to be installed or
libqt5gui5-gles (>= 5.5.0) but it is not going to be installed
qml-module-ubuntu-performancemetrics : Depends: libqt5gui5 (>= 5.0.2) but it is not going to be installed or
libqt5gui5-gles (>= 5.0.2) but it is not going to be installed
qtdeclarative5-ubuntu-content1 : Depends: libcontent-hub0 but it is not going to be installed
Depends: libqt5gui5 (>= 5.0.2) but it is not going to be installed or
libqt5gui5-gles (>= 5.0.2) but it is not going to be installed
qtdeclarative5-ubuntu-ui-toolkit-plugin : Depends: qml-module-ubuntu-components
Depends: qml-module-ubuntu-test but it is not going to be installed
ubuntu-system-settings : Depends: libqt5gui5 (>= 5.0.2) but it is not going to be installed or
libqt5gui5-gles (>= 5.0.2) but it is not going to be installed
Depends: qml-module-qtmultimedia or
qml-module-qtmultimedia-gles but it is not going to be installed
Recommends: ubuntu-system-settings-online-accounts but it is not going to be installed
unity-asset-pool : Depends: adwaita-icon-theme but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

I looked packages which they’re absent or broken (I believe this error happens because of this) but I couldn’t detect any broken packages with Synaptic. Also, some of absent packages that error mentioned are fully installed and not broken. What should i do to solve this? Does installing all the packages that are mentioned solve this problem?