Docker Community Forums

Share and learn in the Docker community.

Unable to install docker on Ubuntu 14.04.5 LTS (GNU/Linux 4.2.0-27-generic x86_64)

I am trying to install docker on linux machine “Ubuntu 14.04.5 LTS (GNU/Linux 4.2.0-27-generic x86_64)” on this version I am trying to install docker with installation steps as per

When I am trying to run the command “sudo apt-get install docker-ce docker-ce-cli” I am getting the below error:
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package docker-ce-cli
Need solution for this ?

is it necessary to install docker ce-cli and containerd ??

There are some extra packages for ubuntu 14.04 linux-image-extra-* packages, which allow Docker EE to use the aufs storage driver and here the commands for them:

$ sudo apt-get update

sudo apt-get install \ linux-image-extra-(uname -r)
and then set up the repository:

sudo apt-get update sudo apt-get install
curl -fsSL <DOCKER-EE-URL>/ubuntu/gpg | sudo apt-key add - apt-key fingerprint 6D085F96

pub 4096R/6D085F96 2017-02-22
Key fingerprint = DD91 1E99 5A64 A202 E859 07D6 BC14 F10B 6D08 5F96
uid [ultimate] Docker Release (EE deb)
sub 4096R/91A29FA3 2017-02-22
sudo add-apt-repository \ "deb [arch=amd64] <DOCKER-EE-URL>/ubuntu \ (lsb_release -cs)
The last installation step of docker-ee:-

sudo apt-get update sudo apt-get install docker-ee
Hope this works for you.

sudo apt-get install docker-ce

I had another problem while installing the above command.on same machine Ubuntu 14.04 version
I am getting below error:

sudo apt-get install docker-ce
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
containerd…io : Depends: libseccomp2 (>= 2.3.0) but 2.1.1-1ubuntu1~trusty5 is to be installed
E: Unable to correct problems, you have held broken packages.

Is there any solution for this or should I run only sudo apt-get install docker-ce instead of sudo apt-get install docker-ce containerd…io ?? Is containerd…io will cover under docker-ce input.

I’m afraid I don’t know the commands on ubuntu, but on Redhat/Centos, you need to install docker-ce and then separately.

sudo dnf install --nobest docker-ce

sudo dnf install

This skips the problematic containerd dependency and then you install it as a standalone installation.