Error Running Docker after fresh installation

I just installed docker on a new cloud VM.
Ubuntu 20.04LTs
kernel: 5.4.174-2-pve

After completing the docker-io installation, I tried running the hello work image but I got an error:

docker: Error response from daemon: failed to create shim: OCI runtime create failed: runc create failed: unable to start container process: error during container init: error mounting "proc" to rootfs at "/proc": mount proc:/proc (via /proc/self/fd/6), flags: 0xe: permission denied: unknown.
ERRO[0000] error waiting for container: context canceled

sudo systemctl status docker

I am new to Docker and would appreciate any assistance in fixing this.


I guess you’re running proxmox since its a -pve kernel?
If so, it will give you this error because the server isnt allowed nesting virtualization, i belive you can enable “nesting” on proxmox somewhere

1 Like

Well spotted. The combination of OS and kernel looks like Ubuntu is running in a lxc container and not in a vm.

Proxmox allows to set wether a lxc container is unpriviliged or not. Only Unprivilged lxc containers allow to enable the feature nesting. Seems the unprivilged setting can only be selected when creating the lxc container.

Update: I just tested it → an unprivliged lxc container with nesting feature enabled does the trick. If the nesting feature is disabled, the error message is the same as your. With a privliged lxc container I get an error regarding a missing apparmor profile.

1 Like

Thank you @terpz @meyay for the suggestions, enabling the nesting virtualization fixed it and all works well now.

1 Like