EXSi 7 VM - Find the right image to install docker on it

I’m more a User Than an Expert on all This server stuff, But want to learn.

To start with Docker, I’m looking for an OFA, OVA, or ISO to set up a VM for using Docker on my tiny ESXi 7 server.

As I understud a VM on ESXi is a virtualization and now in this should be placed another virtualization (nested?) → Docker.

What Linux would you recommand for the ESXi VM to place Docker there?
I started with alpine for Reverse Manager, but without Docker.

For Nextcloud, I used the Core Image from TurnKey Core which is easier to setup. ( for me! ).

As I have to learn Docker from scratch, I now want to set up The VM for Docker properly without Trial and Error.

So The first step is now my question to choose the right Linux to place docker there.

What would you recommand to use?

I think as it is a nested virtualization, the base Linux for Docker should be tiny?
Easy for me would be something like an ISO OVA… ready to use, as setting up Alpine Linux ( which is very tiny) was really hard for me Newbie.

Hope for hints and advices to get the VM up
and then how to set up a Docker environment there.

Many THX for your patience with a newbie! :slightly_smiling_face:

Use Docker-CE (=Docker Engine) on one of the supported distributions, which depending on your choice of flavor is either rpm (Fedora/Centos) or deb (Debian/Ubuntu) based. RHEL and Suse are practically unsupported, as the support only covers the exotic x390x architecture (Z Series).

Docker itself does not require nested virtualization. It requires a Linux kernel. A container is just an isolated process on the Linux Kernel.

Docker Desktop just happens to need a VM because they run a utility vm which provides the Linux kernel and runs the Docker Engine. Docker Desktop for Linux uses a utility vm to guaranty consistent user experience across all variations…

If you like Ubuntu, and ESXi supports cloud init: you can leverage the Ubuntu Cloud images Ubuntu 22.04 (Jammy Jellyfish) [20230302]. Note: they are unusable without cloud init, as it requires a cloud init config to create a user account.

Many THX meyay for taking care.

I have now laboriously a VM with Alpine Linux set up.
I have learned that it is very tiny ad good for setting up Docker on it.

To finally get some results on This machine, I only want to run Bitwarden, but I cannot find a GUID how to do this.

I think there are not too many commands necessary, but I don’t know where to start, what I have read in the meantime made me totally confused
Ubuntu Debian Fedora App package…

If someone has patience with me as newbie, I would kindly ask to drop me the commands Step by Step to have the first sense of achievement.

I managed to be able to log in as root in putty and Win SCP.
Hope to get Bitwarden up and running with your help.

PS: I have copied this machine now that when Bitwarden is running I want to go on learning Docker and set up there I think portainer to get familiar with this Docker stuff.
What do you think is Possible?

I must admit, that I am confused after reading your post.

Especially, if you are a beginner, try to stick to the officially supported distributions and os versions.

I have no idea why there is a screenshot of Bitwarden packages, unless you don’t want to set it up as a container.

Bitwarden is an excellent choice if you have plenty of resources to spare. If you want to save resources, you might want to look at vaultwarden on dockerhub, which is also much easier to install.

Everything? I have no idea what to respond here, it pretty much depends on you knowledge, your motivation, your willingness to learn and how much time you have to spare. Every expert started his/her journey at one point :wink:

If you are looking for step by step instructions, there is almost nothing where you don’t find at least one blog post that meets your need.

Many THX for taking care again!

Meanwhile, I tinkered an installation of Bitwarden, which worked! - Big Surprise!

Now I can reach my VM with the IP of the VM ad can create an Account.

Now The Problem:
As said Tinkered!
During installation, I said:
Domain: bitwarden.local
create no certificate …
Created self-signed certificate…

As my former installation with other Apps worked like this:
setup App in VM
Point Domain with c record to my fritz box router _ > to reverse Manager → to IP of VM
create Certificate with Reverse Manager

Done in same way with Bitwarden VM

I think there is a mess-up done with my installation . Domain & I think mainly with certificates
or I’m using the Wrong Port to address to Docker?
I used 443/80 as in other APPs

What do You Think?

Is there a solution to solve this mess?

I would not mind doing the installation again
What to set This Time?

PS: do you know where else to turn to with this problem?

I think this is off-topic for a Docker forum, as the objective moved away from a docker centered topic, to a Bitwarden centered topic.

I am quite sure there is an official Bitwarden forum, and “Google Consulting” should be able to point you to it.