Docker Community Forums

Share and learn in the Docker community.

Filesharing not enabled. 'Volume sharing is not enabled. On the Settings screen in Docker Desktop' Error 125

I’ve been having this problem with docker for the past week on a new install:
Volume sharing is not enabled. On the Settings screen in Docker Desktop, click Shared Drives, and select the drive(s) containing your project files.

I tried everything… disable firewall, antivirus, new install, restore to default, add folder to docker…nothing works.
The file sharing option doesn’t show the directories shared by docker.

can someone help me with this?

You must be a member of the ‘docker-users’ group in order to have permissions to work with Docker containers. To add yourself to the group in Windows 10, follow these steps:

From the Start menu, open Computer Management.
Expand Local Users and Groups, and choose Groups.
Find the docker-users group, right-click and choose Add to group.
Add your user account or accounts.
Sign out and sign back in again for these changes to take effect.
You can also use the net localgroup command at the Administrator command prompt to add users to specific groups.

@lewish95 it’s not working. I’m using docker edge ver, in Linux Container and wsl version 2 also.

Add C:\ or the specific drive (Z:, etc) to the File Sharing entry.

Due the fact i’m using Windows 10 and “WSL 2” instead of the old “Hyper-V” engine.
I only needed to Check the “Use the WSL 2 based engine” under “General” and did “Apply & Restart” that solved by issue.