Glibc_2.32' not found

I install jenkins in docker,when I run jenkins pipeline get this error:

docker: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.32' not found (required by docker)
docker: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.34' not found (required by docker)

this is the conetnt of jenkinsfile.

pipeline {
    agent {
        docker {
            image 'node:14' 
            reuseNode true 
        }
    }
    stages {
        stage('Test') {
            steps {
                sh 'node --version'
            }
        }
    }
}

Even though it says image 'node:14', are you sure you are really using the official node image?

The official image doesn’t have that problem: docker run -ti --rm node:14 --version

Might be related

Oh, so you are saying the problem is already on the Jenkins agent level? Haven’t thought of it, but it would kind of make sense.

If this is the case, then isn’t it rather a Jenkins or Jenkins agent problem than a docker problem?