How disable proxy for docker engine

Hello

I turn around about a proxy problem with docker in pulling opérations.
I get the message below.

Error response from daemon: Get “https://registry-1.docker.io/v2/”: proxyconnect tcp: dial tcp: lookup myproxy.net on 192.168.43.1:53: server misbehaving

So, i would like to be sure the proxy is the cause.
for that, i would like to use docker without proxy trough my mobile connection.

I decide to remove http-proxy.conf file in /etc/systemd/system/docker.service.d
Same thing for ~/.docker/config.json

after that i reload the daemon and restart the service with commands below.

$ sudo systemctl daemon-reload
$ sudo systemctl restart docker

Here, there is something weird…

In the output of the command below, i get lines for Http Proxy and Https proxy, and this lines are well valued.

$ docker info

Is there another way to disabled proxy for docker ?

in following the docker’s documentation i didn’t find answer

Thanks by advance for your help
grome55

SMP Debian 5.10.149-2 (2022-10-21) x86_64 GNU/Linux
docker Client: Version: 20.10.5+dfsg1
docker Engine: Version: 20.10.5+dfsg1

i found !

there was proxy settings in /etc/default/docker
so even when i removed the file .conf for systemd in /etc/systemd/system/docker.service.d
proxy settings were enabled.

1 Like