Docker Community Forums

Share and learn in the Docker community.

How to disable control-r hijack on windows

Using Windows 11 with Docker Desktop 4.4.3 (73365):
Docker seems to highjack Control-r for Docker restart.
Is there a way to prevent it? I prefer Reverse Search in terminals with ctrl-r
Thanks a lot

2 Likes

I didn’t know there was a new version but now I upgraded it to the same version on my Windows 11. It didn’t do anything on Ctrl+r. I was ready to say that it was a bad idea to implement a feature like that, but it seems there is no such feature at least not by default. I even restarted my Windows to see if that matters.

In which terminal you try Ctrl+r? Powershell? WSL2? Container terminal on Docker Desktop?

Is this restarting the Docker daemon or just a container? How do you know that it was restarted?

It’s no longer doing being captured - there was a bugfix for this behaviour in 4.4.3:

  • Disabled Dashboard shortcuts to prevent capturing them even when minimized or un-focussed. Fixes docker/for-win#12495.

So I guess I hadn’t fully restarted Desktop and hadn’t seen the fix yet.

I am confused. You wrote that the error happens using Docker Desktop 4.4.3 (73365) which is exactly the version I have now. Now you say it was fixed and I see that a relase note added to 4.4.3 mentioning that CTRL+R shortcut was disabled. So are you sure you used 4.4.3 when the restarting happened? How could a patch version be released using the same version number?

I can confirm as the last upgrade fully resolves this “feature”. After a computer restart Docker Desktop won’t pops up any context window regarding.
You can also check this code snipet in C:\Program Files\Docker\Docker\frontend\resources\app.asar between lines 3755 and 3810, search for “CmdOrCtrl+R”.

message: ‘Restart Docker Desktop’,
detail: ‘You are about to restart Docker Desktop. A restart stops all running containers. No data will be lost otherwise.\n\nDo you want to continue?’,

1 Like

Yes it’s fixed for me.
I think the important part is that you have to restart your machine, not just Docker.

See my edit.
I think it needs a machine restart, not just docker restart.