Docker Community Forums

Share and learn in the Docker community.

Proxy enabled flag ignored?


(Mh2015) #1

Expected behaviour

When I enable or disable webproxy or secure web proxy in System Preferences - Network the http_proxy, https_proxy env variables in docker host are not updated in all cases.

Actual behaviour

Docker for Mac does recognise when the proxy server name is removed in system preferences - network and restarts the VM, but does not recognise if the proxy is just disabled.

Information

  • the output of:
    • Moby Menu > Diagnose & Feedback on OSX
      Docker for Mac: version: mac-v1.12.0-beta17
      OS X: version 10.11.6 (build: 15G24b)
      logs: /tmp/20160703-105726.tar.gz
      [OK] docker-cli
      [OK] app
      [OK] menubar
      [OK] virtualization
      [OK] system
      [OK] osxfs
      [OK] db
      [OK] slirp
      [OK] moby-console
      [OK] logs
      [OK] vmnetd
      [OK] env
      [OK] moby
      [OK] driver.amd64-linux

Steps to reproduce the behavior

  1. Webproxy and secure webproxy server and port defined and enabled in System Preferences - Network

  2. Start docker for Mac

  3. Check the env vars on the docker host:
    -> http_proxy and https_proxy are set. That’s correct

  4. Disable web proxy and secure web proxy in System Preferences - Network by unchecking both, but leave the server name and port.
    -> http_proxy and https_proxy in the docker VM are still set. This is wrong.

  5. Remove the proxy server name and port in System Preferences - Network.
    -> Docker for Mac restarts the vm
    -> http_proxy and https_proxy env vars are no longer set.


(roovo) #2

I’ve raised a ticket on github for a similar issue:

[https://github.com/docker/docker/issues/24033]

I didn’t realise when I created it that you could get it to update the settings when removing the name and port in system preferences (I was just changing them and seeing that they didn’t update) so you could add your experience to the ticket so it’s more complete…

Someone’s suggested being able to set up the proxies like firefox does on there too, which sounds like a great idea…


(Mh2015) #3

I didn’t recognise that it only detects if you remove or enter the server/port, but not if you change them. My problem is that just enabling(disabling the proxy setting is not picked up.