How to turn off the What's New message?

Is there a way to turn off the following promotional message?

“What’s next?
Try Docker Debug for seamless, persistent debugging tools in any container or image → docker debug sqlserver
Learn more at docker debug | Docker Docs

It seems to be appended to the return message from running the following type of command:

docker exec -it sqlserver /opt/mssql-tools/bin/sqlcmd -S localhost -U sa -P “ZZZZZZ” -Q “SELECT Name from sys.Databases”

Name                                                                                                                            
--------------------------------------------------------------------------------------------------------------------------------
master                                                                                                                          
tempdb                                                                                                                          
model                                                                                                                           
msdb                                                                                                                            
AdventureWorksDW2022                                                                                                            

(5 rows affected)

What's next?
  Try Docker Debug for seamless, persistent debugging tools in any container or image → docker debug sqlserver
  Learn more at https://docs.docker.com/go/debug-cli/

System: Win 11 + WSL2 + Docker Desktop

2 Likes

Also would like to know - annoying.

For those wanting a quick fix, you may be able to leave off the interactive (-i) flag on your docker commands. For us a simple:

docker exec -t bin/run-tests

…is sufficient. If you need an interactive shell, we’ll have to wait for Docker to offer an option to remove this new spam idea someone cooked up.

1 Like

Looks like there’s an environment variable DOCKER_CLI_HINTS. Setting that to false removed the spam for me.

DOCKER_CLI_HINTS=false

1 Like

I am trying to follow these instructions…

When I go to Docker Desktop > Settings > Show CLI hints > Uncheck > Apply & restart…

The spam is no longer returns from docker commands (linux terminal).

The spam still returns for docker commands prefixed with sudo (linux terminal).

Is any solution for this. because untick setting didn’t work for me.
Getting useless hints after each second row in terminal already pisses me off.

The DOCKER_CLI_HINTS environment variable worked for me. In case others encounter the same situation, I use Docksal (similar to Lando, DDev, etc.) that spins up Docker containers configured for my project. Those containers, all need the variable present. With some of these applications, simply establishing the variable on your host machine is not sufficient. So, if you use similar setups for app development you’ll need to figure out how to pass that environment variable into your project’s containers.

For Docksal, you can simply add DOCKER_CLI_HINTS="false" in your docksal-local.env config file. But I realize Docksal is one of the lesser used tools that exist for this kind of development.