Docker Community Forums

Share and learn in the Docker community.

Huge com.docker.hyperkit memory usage and aclocal failure


(Dantswain) #1

I’m using a gentoo-based image to compile some C++ libraries. When I run certain make commands using the image, the memory of com.docker.hyperkit shoots up to the multi-gigabyte range and I get config errors along the lines of

[  0%] Performing configure step for 'libuv'
+ libtoolize
+ aclocal -I m4
Out of memory!

I’ve gotten similar errors with an ubuntu-based image as well. This is reproducible for me in the sense that I can delete all of my containers, images, and volumes, build the image from scratch, delete the contents of the build directory, and still get the same error. I’ve tried with both Docker for Mac beta and stable.

My suspicion is that this could be related to the size of the volume that I’m mounting - it’s got several C++ dependencies, including boost, so a very large number of files. However, even if the entire contents of the volume were stored in memory it wouldn’t account for the memory usage I’m seeing for com.docker.hyperkit.

Note I can run this same build script on a linux host with docker and it works fine.

Below is my current docker info. I can try to provide more but I’m not familiar enough with docker to know what might be useful unless someone asks for it. I can try to find a minimal reproducible example - this is a little tricky because it’s part of a fairly complex build script for something proprietary.

Thanks!

$ docker info
Containers: 0
 Running: 0
 Paused: 0
 Stopped: 0
Images: 4
Server Version: 1.12.0
Storage Driver: aufs
 Root Dir: /var/lib/docker/aufs
 Backing Filesystem: extfs
 Dirs: 6
 Dirperm1 Supported: true
Logging Driver: json-file
Cgroup Driver: cgroupfs
Plugins:
 Volume: local
 Network: bridge null host overlay
Swarm: inactive
Runtimes: runc
Default Runtime: runc
Security Options: seccomp
Kernel Version: 4.4.15-moby
Operating System: Alpine Linux v3.4
OSType: linux
Architecture: x86_64
CPUs: 4
Total Memory: 13.68 GiB
Name: moby
ID: CSLR:UZYZ:3F5R:3DZQ:U4PR:5BNO:75KP:ZXZF:RDMC:7KZD:NP43:O2VT
Docker Root Dir: /var/lib/docker
Debug Mode (client): false
Debug Mode (server): true
 File Descriptors: 17
 Goroutines: 29
 System Time: 2016-08-25T16:30:39.099777237Z
 EventsListeners: 1
No Proxy: *.local, 169.254/16
Registry: https://index.docker.io/v1/
Insecure Registries:
 127.0.0.0/8

(David Sheets) #2

Please use the Diagnose & Feedback feature of the app to report this issue with diagnostic bundle to the GitHub issue tracker. As a first guess, it sounds like the amount of memory given to Docker may be too low. Have you tried increasing the memory allocation in Preferences?


(Dantswain) #3

Thanks @dsheets, I’ll try to reproduce the issue (I’ve been working around it for the last few days) and file an issue.

I already have 14GB of RAM allocated to docker - that really should be plenty for the code I’m trying to execute :confused:


(Dantswain) #4

I was able to reproduce the issue and filed an issue here: https://github.com/docker/for-mac/issues/495