I can't download docker Desktop

Hello, so I’m trying to use Docker to test my app. My issue is I can’t download docker to do so. When I click on the “Install for windows” button, it’ll load forever. I’ve waited for 30 minutes so far, yet no avail. Can someone tell me a fix/workaround for this?

Thanks!

My OS is Windows 10,
My browser is: Chrome

Where is that “Install for Windows” button? I tried two ways a moment ago and both worked.

  1. Install Docker Desktop on Windows | Docker Documentation (Click on "Docker Desktop For Windows)
  2. Docker Desktop for Mac and Windows | Docker (Click on Windows in the line: Also available for Windows and Linux)

I’ve clicked those buttons but the download doesn’t ever start. Here’s a video of it

Im not sure why this is happening

It can be some kind of network issue between desktop.docker.com and your machine or a firewall which blocks downloading exe files. You could

  • try a VPN
  • try a other browser or private window
  • try to copy the link address (right click and Copy link address or similar) and download it from a terminal
  • Disable your firewall on Windows (I know for a very short time until you try t download the desktop)
  • Use an other machine to download the Desktop
  • try nslookup from a terminal like: nslookup desktop.docker.com to see if the domain name can be resolved. If not, try to change your DNS settings to use an other DNS server. For example: 8.8.8.8 from Google.

how would I download via a terminal? Also thanks for your help

If you have WSL on your Windows, you can use curl or wget. From Powershell, Invoke-Webrequest could help you: Invoke-WebRequest (Microsoft.PowerShell.Utility) - PowerShell | Microsoft Docs

Hey dude, thanks for your help! I was able to get it working using command prompt and typing this code to make it download:

winget install Docker.DockerDesktop

It took me about 5 minutes for it to download. But I can’t complain since it downloaded!

Thanks for your help bro :+1:

1 Like