Docker Community Forums

Share and learn in the Docker community.

I can't start a Docker desktop

I’m not able to start a Docker Desktop application. It shows me no error log and I can’t see a task tray icon of the Docker Desktop.
I realized that I can’t start WSL too. I think this is the problem that the Docker Desktop can’t start.

I googled it but I finally didn’t find out how to fix the problem.

The error is below.

Installing, this may take a few minutes...
WslRegisterDistribution failed with error: 0x8007273f
Error: 0x8007273f An address incompatible with the requested protocol was used.

Press any key to continue...

I’ve tried some ways that I googled to fix it but I wasn’t able to fix.

Does anyone know about this problem?
Let me know everything you think about.

1 Like

I’ve had the exact same problem and I somehow managed to overcome it but I’m not exactly sure as to which tweak actually did the trick. Here is some background and the things I tried to fix the situation.

My windows-driven local-dev environment recovered from some kind of exotic freak-accident affecting “Docker Desktop.exe”. I’ve set it to run with the standard WSL / Ubuntu configuration (nothing too fancy). HyperV has never been enabled on my machine nor has Docker ever been set to use it. I was always using WSL from day 1.

In my case even though the Docker Desktop service was up and running in “services.msc”, for some weird reason, “Docker Desktop.exe” simply would not launch properly no matter what I tried. The process would launch and then die silently a few seconds later with no trace of what went wrong in Windows Event Viewer.

  • I deleted all configs and stores in my home directory and under C:\ProgramData → no effect
  • Reinstalled ver. 3.6.0 → no effect
  • Installed ver. 4.0 → no effect
  • Multiple restarts → no effect
  • Try launching from the command line → no effect
  • Try with admin-privileges → no effect

In the end I installed the latest .net 4.8 SDK and the latest 4.7.2 sdk and I also approved Windows Update → restarted → now docker ver. 4.0 works fine again (go figure …)

Thank you for replying! You finally solved with installing .NET4.8 SDK / .NET4.7.2 SDK, right?
I’ve already updated windows-updates, so I’ll try them!