Image can no longer connect to usb device

I’ve used a Docker container to flash my ST devices for the past two years, and never had a problem. Today I tried to use it, and the image has stopped working – on two different computers.

I keep up-to-date. Does anyone know of any recent updates to Docker or Linux (Ubuntu) that would have altered the USB driver?

$ docker run --device /dev/bus/usb --rm --tty --volume ~/Downloads/:/host-volume/ stm32_programmer_cli --connect port=USB1 --write /host-volume/notecard- 0x08000000 --verify --go
                        STM32CubeProgrammer v2.11.0                  

Error: Target device not found
Establishing connection with the device failed

I probably used this successfully about a month ago… I have not rebuilt any images, so nothing has changed there. I have to believe Docker or Linux has changed underneath.

Computer 1:

$ docker --version
Docker version 24.0.2, build cb74dfc
$ uname -a
Linux FRAMEWORK 5.19.0-45-generic #46~22.04.1-Ubuntu SMP PREEMPT_DYNAMIC Wed Jun 7 15:06:04 UTC 20 x86_64 x86_64 x86_64 GNU/Linux

Computer 2:

$ docker --version
Docker version 20.10.15, build fd82621
$ uname -a
Linux blues-serval-ws 6.2.6-76060206-generic #202303130630~1683753207~22.04~77c1465 SMP PREEMPT_DYNAMIC Wed M x86_64 x86_64 x86_64 GNU/Linux

P.S. I also tried multiple ST devices, just to make sure one wasn’t burned out.