Docker Community Forums

Share and learn in the Docker community.

In search of a stable distro/docker combo for running on AWS


(Babysnakes) #1

Hey All,

I’ve been running docker on production for almost 2 years now (on about 80 - 150 busy ec2 instances) and I’m still looking for a stable docker/distro/setup. Currently it’s becoming an urgent topic for us (see below) and I want to hear from your experience. So far I’ve tried:

  • CoreOS (the relevant version for 1.5 years ago) on btrfs - It run quickly but suffered from problem under load (CoreOS, not docker).
  • For a long time I was running on AmazonLinux and various docker versions (last was 1.7.1) with device mapper and LVM. This was very stable and used successfully for about 1.5 years, until I discovered that Amazon Linux doesn’t support locking yourself to a version and getting security updates (which is unfortunate).
  • In the last few days I tried running CentOs 7 with docker 1.10.3 using DM and LVM thinpool. This one really fails miserably. Of the 5 machines that run for 2 days, one docker instance was completely stuck and couldn’t be killed, and three were acting like there is no space left on the device although docker info indicates that there still is 7G available. Because both CoreOS and CentOs 7 were using systemd I started to suspect that maybe that is the problem?

So, I’m looking for a stable linux distribution (e.g. debian testing won’t work for us) with security updates and most important runs docker without issues even under heavy load.

Any suggestions?

Thanks.

Haim


(Parity3) #2

Hi Haim,

Now that it’s been 21 months since you posted your question, I’m wondering if you found any solutions that worked since then?


(Babysnakes) #3

Wow, this is a long time ago. IIRC when I first tested it I followed a procedure to create LVM initpool manually - possibly that’s what I describe here. I then switched to docker RPM that was provided by RedHat and it has a docker-storage-setup that handles LVM itself and I work on that without a problem since. However, note that this docker is very outdated (1.12.x).

I’m going to switch to orchestration soon so the search is on :slight_smile:.