Docker Community Forums

Share and learn in the Docker community.

Installation on opneSuSE 12.3 doesn't work because of kernel version


(Maeder) #1

I tried to install docker on my openSuSE 12.3 box according to https://docs.docker.com/installation/openSUSE/. This doesn’t work:

zypper install docker
Loading repository data…
Reading installed packages…
Resolving package dependencies…
Problem: nothing provides kernel >= 3.8.0 needed by docker-1.2.0-24.4.x86_64
Solution 1: do not install docker-1.2.0-24.4.x86_64
Solution 2: break docker-1.2.0-24.4.x86_64 by ignoring some of its dependencies

This installation guide was apparently not tested on openSuSE 12.3 :frowning:


(Maeder) #2

I’d like to try to reproduce the problem. I did a basic account creation test on OS X Mavericks, Firefox 33.0 and didn’t see a problem. Could you let me know your operating system version and browser version?

OpenSuse 12.3
Firefox (latest version)


(Christopher De Boever) #3

I’m seeing the same error when trying to install on 12.3.

$ sudo zypper in docker
<snip>
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: nothing provides kernel >= 3.8.0 needed by docker-1.3.1-27.1.x86_64
 Solution 1: do not install docker-1.3.1-27.1.x86_64
 Solution 2: break docker-1.3.1-27.1.x86_64 by ignoring some of its dependencies

Here is my OS version:

$ cat /etc/os-release
NAME=openSUSE
VERSION="12.3 (Dartmouth)"
VERSION_ID="12.3"
PRETTY_NAME="openSUSE 12.3 (Dartmouth) (x86_64)"
ID=opensuse
ANSI_COLOR="0;32"
CPE_NAME="cpe:/o:opensuse:opensuse:12.3"